Lets Encrypt API change

I’m having trouble provisioning a new certificate using the automated Let Encrypt button in the mailinabox admin panel.
I get the error: “You should register before running non-interactively, or provide --agree-tos and --email <email_address> flags.”
The /var/log/letsencrypt.log file says the same thing in a much more verbose fashion, suggesting that it’s certbot which is falling over.
It looks to me as if there’s been a minor change to the an API somewhere, but I don’t know enough about the internals to add the required fields myself. Can somebody please suggest a way forward?

Many thanks.

Hi there, :wave:

Did you upgrade to v0.28 just now? I ran into an issue with certbot after upgrading to 0.28, which I described here https://github.com/mail-in-a-box/mailinabox/issues/1409 . The fix for me was to run sudo mailinabox within the box (which re-runs the v0.28 setup), and agree to the Certbot terms of service.


Thats fantastic, thank you. I’d tried a couple of reinstallations using the curl -s https://mailinabox.email/setup.sh | sudo bash command, but sudo mailinaboxdid the trick.

cheers :slight_smile:


Also see https://github.com/mail-in-a-box/mailinabox/issues/1409.

Works great. Thanks nilsnh!

Note for people for whom it might not be clear: running sudo mailinabox will not wipe everything it will just do the upgrade and let you Accept the certbot question during the process.

1 Like

It solved the problem. Thanks nilsnh!

I am getting this issue again in v0.40. I have ran the mailinabox command a few times and I have never been asked to accept the mailinabox TOS or anything.

Anyone else have any issues?

Please PM me if possible or open a new thread.

The Let’s Encrypt ToS agreement is now done in the install script itself, so you will not see it, but rather a message that MiaB is accepting LE’s terms.

What exactly are you getting as an error, or what is not working / happening?

And I agree with Murgero - this should be in a new thread, thanks!