IPv4 issues system down

I am having very unusual behavior with my system (which is proving quite beyond my capabilities to solve). It failed around a week ago, and I restored from backups successfully (by creating an entirely fresh instance and using the duplicity command from the maintenance guide), but it seems to be having the same issue again today (after working with no troubles in the meantime), so I am hoping I can get to the bottom of it quickly rather than restore and face the same issue again potentially later.

I am going to list the few things that seem relevant/curious to me, but don’t really have any ideas of how to troubleshoot further.

I can ping my box using an IPv4 address from outside the network and it works, but I cannot ping out of my box to IPv4 addresses (it times out). However, I can ping6 out to IPv6 addresses. Also, I cannot SSH into my box (it is a virtual machine on a Proxmox server that I moved it to a few weeks ago, so I can access it through the Proxmox server’s terminal).

While it cannot ping out, when I run sudo apt update, it checks Ubuntu’s repositories as usual and doesn’t throw any errors. (Maybe it’s using IPv6 for that).

Currently, all ports are blocked by ufw except 22/tcp because I am hoping to fix it in time that any incoming mail will be retried (that way I don’t need to track down emails that come to my box in the meantime). Last time this happened, I did get a few emails after this problem occurred, again maybe with IPv6.

I tried disabling IPv6 in the netplan config and rerunning sudo mailinabox and it didn’t throw any errors, but also didn’t help.

I am running an unmodified install of Ubuntu 22.04 and the latest version of Mail-in-a-Box.

Difficult to say where to start, but to help us get a better picture, and perhaps some things you can look at:

  • You mention the system failed, but what exactly failed?
  • What is the output of the System Status Checks in the admin portal? (Can you access it?)
  • How are you hosting this? Which VPS provider?
  • Does the VPS provider have a firewall?
  • Is your UFW blocking something?

Thanks for your reply!

I figured it out. It was Fail2ban was blocking the static ip to our office (one of our users I think must have forgotten their password and set it off both times). I was pinging that static ip because it was one that I knew was only IPv4 and it happened to be the one that was blocked. I should have realized to try more than one, but because it was the very one I was on and using to talk to our Proxmox server with, it didn’t occur to me that it could be the problem.

I have added a config file to /etc/fail2ban/jail.d/something.conf with
ignoreip = … [the various IPs we want whitelisted]

and that seems to have done the trick and it survives sudo mailinabox.

Thanks again.

This topic was automatically closed 40 days after the last reply. New replies are no longer allowed.