IONOS + Ubuntu 22.04.1 + Miab v60.1 installation failure

Hello all,

like lots of you i suppose, i wish to use Miab on Ubuntu 22.04.
i created a new VPS on Ubnutu at Ionos provider

Ionos delivered me a VPS running on Ubuntu 22.04.1 LTS (GNU/Linux 5.15.0-52-generic x86_64)
It is up to date regarding OS patches.

to install from scratch Miab, I ran Linux command from home user directory :
sudo curl -s https://mailinabox.email/setup.sh | sudo bash

Log extracts:

Downloading Mail-in-a-Box v60.1. . .
Installing packages needed for setup…

Primary Hostname: box.XXX.tld
Public IP Address: XX.XXX.XXX.XXX
Private IPv6 Address: fexxxxxxxxx │
Mail-in-a-Box Version: v60.1

Installing nsd (DNS server)…

FAILED: apt-get -y -o Dpkg::Options::=–force-confdef -o Dpkg::Options::=–force-confnew install nsd ldnsutils openssh-client

Reading package lists…
Building dependency tree…
Reading state information…
openssh-client is already the newest version (1:8.9p1-3).
The following additional packages will be installed:
libevent-2.1-7 libfstrm0 libldns3 libprotobuf-c1
The following NEW packages will be installed:
ldnsutils libevent-2.1-7 libfstrm0 libldns3 libprotobuf-c1 nsd
0 upgraded, 6 newly installed, 0 to remove and 2 not upgraded.
Need to get 950 kB of archives.
After this operation, 3,057 kB of additional disk space will be used.
Ign:1 Index of /ubuntu jammy/main amd64 libevent-2.1-7 amd64 2.1.12-stable-1build3
Ign:2 Index of /ubuntu jammy/universe amd64 libfstrm0 amd64 0.6.1-1
Ign:3 Index of /ubuntu jammy-updates/main amd64 libprotobuf-c1 amd64 1.3.3-1ubuntu2.1
Ign:4 Index of /ubuntu jammy/universe amd64 nsd amd64 4.3.9-1
Ign:5 Index of /ubuntu jammy/universe amd64 libldns3 amd64 1.7.1-2ubuntu4
Ign:6 Index of /ubuntu jammy/universe amd64 ldnsutils amd64 1.7.1-2ubuntu4
Ign:1 Index of /ubuntu jammy/main amd64 libevent-2.1-7 amd64 2.1.12-stable-1build3
Ign:2 Index of /ubuntu jammy/universe amd64 libfstrm0 amd64 0.6.1-1
Ign:3 Index of /ubuntu jammy-updates/main amd64 libprotobuf-c1 amd64 1.3.3-1ubuntu2.1
Ign:4 Index of /ubuntu jammy/universe amd64 nsd amd64 4.3.9-1
Ign:5 Index of /ubuntu jammy/universe amd64 libldns3 amd64 1.7.1-2ubuntu4
Ign:6 Index of /ubuntu jammy/universe amd64 ldnsutils amd64 1.7.1-2ubuntu4
Ign:1 Index of /ubuntu jammy/main amd64 libevent-2.1-7 amd64 2.1.12-stable-1build3
Ign:2 Index of /ubuntu jammy/universe amd64 libfstrm0 amd64 0.6.1-1
Ign:3 Index of /ubuntu jammy-updates/main amd64 libprotobuf-c1 amd64 1.3.3-1ubuntu2.1
Ign:4 Index of /ubuntu jammy/universe amd64 nsd amd64 4.3.9-1
Ign:5 Index of /ubuntu jammy/universe amd64 libldns3 amd64 1.7.1-2ubuntu4
Ign:6 Index of /ubuntu jammy/universe amd64 ldnsutils amd64 1.7.1-2ubuntu4
Err:1 Index of /ubuntu jammy/main amd64 libevent-2.1-7 amd64 2.1.12-stable-1build3
Temporary failure resolving ‘archive.ubuntu.com
Err:2 Index of /ubuntu jammy/universe amd64 libfstrm0 amd64 0.6.1-1
Temporary failure resolving ‘archive.ubuntu.com
Ign:3 Index of /ubuntu jammy-updates/main amd64 libprotobuf-c1 amd64 1.3.3-1ubuntu2.1
Err:4 Index of /ubuntu jammy/universe amd64 nsd amd64 4.3.9-1
Temporary failure resolving ‘archive.ubuntu.com
Err:5 Index of /ubuntu jammy/universe amd64 libldns3 amd64 1.7.1-2ubuntu4
Temporary failure resolving ‘archive.ubuntu.com
Err:6 Index of /ubuntu jammy/universe amd64 ldnsutils amd64 1.7.1-2ubuntu4
Temporary failure resolving ‘archive.ubuntu.com
Err:3 Index of /ubuntu jammy-updates/main amd64 libprotobuf-c1 amd64 1.3.3-1ubuntu2.1
Temporary failure resolving ‘archive.ubuntu.com
E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/libe/libevent/libevent-2.1-7_2.1.12-stable-1build3_amd64.deb Temporary failure resolving ‘archive.ubuntu.com
E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/universe/f/fstrm/libfstrm0_0.6.1-1_amd64.deb Temporary failure resolving ‘archive.ubuntu.com
E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/p/protobuf-c/libprotobuf-c1_1.3.3-1ubuntu2.1_amd64.deb Temporary failure resolving ‘archive.ubuntu.com
E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/universe/n/nsd/nsd_4.3.9-1_amd64.deb Temporary failure resolving ‘archive.ubuntu.com

Installation ended with those DNS Resolution error.
that is true, resolving does not work for archive.ubuntu.com

i reintialized the VPS to have again a fresh OS
i did DNS resolving tests : archive.ubuntu.com is resolved

I ran again Miab installation and had again this DNS Resolution issue.
DNS resolution works good before Miab installation and fails during Miab installation process

with my current Miab VPS running on Ubuntu 18.04 I got @IP for archive.ubuntu.com
I added IP address given on new VPS in /etc/hosts file

I ran again Miab install using dedicated command line, but nothing started.

Does someone have this same strange issue ?


Best regards
François

1 Like

I’ve seen the install get confused about the DNS server address.

Try nslookup www.google.com … if that fails, replace 127.0.0.1 in /etc/resolv.conf with the address of a working name server, then rerun the install.

1 Like

Hello Andrew

I’m sorry I do not understand what you are meaning.

i posted a message to have Changelog v60.1 (Changelog for v60.1)
Alento posted it.

there is a DNS issue (hopefully fixed), it seams it is not as i have DNS Resolution issue on a Fresh Ubuntu 22.04.

i will wait for v60.2


Best regards
François

CHANGELOG
=========

Version 60.1 (October 30, 2022)
-------------------------------

* A setup issue where the DNS server nsd isn't running at the end of setup is (hopefully) fixed.
1 Like

Hello,

The issue with nsd does not have an effect on the issue that you are experiencing.

MiaB uses nsd for serving DNS to the outside, but uses bind9 for DNS lookups.

1 Like

I think that your issue may be Ionos. I have seen and heard reports that they make tweaks to the OS templates that they use. This MAY be the problem, but I cannot guarantee it.

1 Like

Hello,

DNS Resolution works well from Ubuntu 22.04.1 fresh install by Ionos Provider

root@localhost:~#More /etc/resolv.conf
nameserver 127.0.0.53
options edns0 trust-ad
search .

root@localhost:~# sudo apt-get update && sudo apt-get upgrade
Get:1 Index of /ubuntu jammy-security InRelease [110 kB]
Hit:2 Index of /ubuntu jammy InRelease
Get:3 Index of /ubuntu jammy-updates InRelease [114 kB]
Get:4 Index of /ubuntu jammy-backports InRelease [99.8 kB]
Get:5 Index of /ubuntu jammy-updates/main amd64 Packages [695 kB]
Fetched 1,020 kB in 1s (857 kB/s)
Reading package lists… Done
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
Calculating upgrade… Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

root@localhost:~# nslookup www.google.com
Server: 127.0.0.53
Address: 127.0.0.53#53

Non-authoritative answer:
Name: www.google.com
Address: 142.250.184.196
Name: www.google.com
Address: 2a00:1450:4001:830::2004

No DNS Resolution issue.

DNS Resolution becomes KO during Miab Installation.

which workaround could i apply ?


Best regards
François

1 Like

in fact, /etc/resolv.conf file is modified during Miab installation

i just try to install Miab again and it fails again :

E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/libe/libevent/libevent-2.1-7_2.1.12-stable-1build3_amd64.deb Temporary failure resolving ‘archive.ubuntu.com
E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/universe/f/fstrm/libfstrm0_0.6.1-1_amd64.deb Temporary failure resolving ‘archive.ubuntu.com
E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/p/protobuf-c/libprotobuf-c1_1.3.3-1ubuntu2.1_amd64.deb Temporary failure resolving ‘archive.ubuntu.com
E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/universe/n/nsd/nsd_4.3.9-1_amd64.deb Temporary failure resolving ‘archive.ubuntu.com
E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/universe/l/ldns/libldns3_1.7.1-2ubuntu4_amd64.deb Temporary failure resolving ‘archive.ubuntu.com
E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/universe/l/ldns/ldnsutils_1.7.1-2ubuntu4_amd64.deb Temporary failure resolving ‘archive.ubuntu.com
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

root@localhost:~# more /etc/resolv.conf
nameserver 127.0.0.1

File has been modified during Miab setup.
why original settings are modified ?

even if i set again /etc/resolv.conf with original values, nothing works, system is unstable.
linux command lines seems not to work.

very strange.


Best regards
François

1 Like

Mail in a Box uses bind9 as a local DNS resolver. As you have seen, this replaces the original system settings. It might not come up for some reason. Perhaps you can see an issue there with sudo systemctl status bind9 ?

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

This is how I worked it out:

  1. Fresh Ionos Ubuntu 22.04.01 VPS deployment.
  2. As root:
    apt update
    apt install bind9
    nano /etc/bind/named.conf.options
  3. Change “dnssec-validation auto” to “dnssec-validation no”, then save file.
  4. Install MIAB v60.1

WARNING/DISCLAIMER: This solution has security concerns. It might not be appropriate to your needs. Proceed at your own peril.

I was desperate for a solution, because I wasn’t able to install a fresh Ubuntu 18.04 for reasons too long to explain here. I will start again with a fresh Ubuntu 22.04.1 box when a new MIAB version is available.

I would appreciate if anyone of you can help on how to install MIAB v60.1 on IONOS Ubuntu 22.04.1 VPS with another, better solution.

2 Likes

What exact issue were you facing?

1 Like

I was facing exactly the same issue presented by @Anonymous78f in this post:

Essentially, the resolver ceased working right after installing bind9.

1 Like

Man you’re a lifesaver!! I’ve been struggling with my Ionos VPS for days, unable to bypass the DNS issues. This solution worked like a charm!

Thank you so much for sharing this!

1 Like

Thanks for your work crazySpaniard. I am having the same problem, but i am having a different provider.
After the installation. Is it possible to revert the changes? Did you try it?

auto means yes if you changed it to no and it worked. So DNS-Sec is a Problem. Can it happen if the old server had dns-sec on for MiaB? I have used DNS-Sec on my old MiaB.

I want to test on the weekend. Then i have more time.

Greetings Chriz

1 Like

I am glad it also worked for you. It can certainly be reverted after installation, but I haven’t tried yet and I do not know if the box would still work after reversal. I am not a DNSSEC or Bind9 expert, so to me it took some hours of work to trace the problem to DNSSEC validation.

My suggestion is you restart bind9 service after reversal and then check if the box is able to resolve some assorted domain names with ping/nslookup.

1 Like

I just did what you are asking:

  1. As root:
    nano /etc/bind/named.conf.options
    Revert dnssec-validation from “no” to “auto”.
    Save & exit.
  2. As root:
    service bind9 restart
    systemctl restart systemd-resolved
  3. sudo mailinabox (to test if installation/reconfiguration works)
  4. Web interface: System → Status Checks

Apparently, the box is still running and resolving all domains… but I made no serious test.

2 Likes

Now im on 60.1 too. Everything is working now crazySpaniard. :slightly_smiling_face:

Had some Temporary failure in name resolution, but didn’t break the install process.
Nextcloud was not on the latest Version…But after restoring my backups and run sudo mailinabox again the installer updated Nextcloud and now everything is working without problems.

Strange Problem with DNS. I reverted the bind9 config too.
Thanks.
Greetings Chriz

1 Like

Hi crazySpaniard

I would like to thank you very much for this workaround.
it permits me this weekend to succeed in my move from OVHcloud VPS Provider to Ionos.

Once move was completed effective and DNS settings (System Ckecks) all back to green, i set back dnssec-validation from “no” to “auto"

Sending and Receiving emails is working like a charm.

Again, I thank you.


Best Regards
François

1 Like

I also join the “thank you” for crazySpaniard, I had the same blocking problem this weekend and your post quickly addressed the situation.

Thank you!

F

1 Like