`✖ Incoming Mail (SMTP/postfix) is not running (port 25).` after upgrade to 0.40


#1

Upgraded a Strato VPS:
First issue:
The same as @yonkoc

Second: I got the installer to:
Initializing system random number generator...
Creating SSH key for backup…
Firewall is active and enabled on system startup
When I got the error:
Failed to restart systemd-resolved.service: Unit systemd-resolved.service is masked.

I had to run systemctl unmask systemd-resolved.service

Now I have one rather important issue left:
Incoming Mail (SMTP/postfix) is not running (port 25).

Anyone know what to do about this? I have rebooted and rerun the install script a couple of times but it does not solve the problem. I have run ufw status but the port shows as allowed anywhere.

The first 2 issues are solved. The third issue is stil present.


#2

I ran the steps to restore a local backup again.
sudo apt-get purge postfix
Ran the mailinabox installer again followed by reboot.

Seems everything is working now. :slight_smile:


#3

Aah … so the VPS likely had a version of postfix installed which interfered. Thanks for sharing the fix. :slight_smile: