IMAP server disconnects after 0.41 upgrade

I’d been using MIAB for years with no issues. Finally got around to doing all the work to upgrade my Digital Ocean server to the new Ubuntu, did the full upgrade/restore. Now, none of my email clients can open any folders. I even installed Thunderbird, in case my old email programs had something cached. Clients tell me the server had disconnected when trying to open the folder. Created a new user, still no luck. Tried using no SSL, even tried accessing via POP.
SMTP works fine, and viewing mail with RoundCube works fine. I’ve searched the forums with no one reporting any issues like this. Before I just copy off all my data, and start over from scratch, any ideas?


Check the owners on the mail folders. If the restore went properly they should be owned by the user:group mail:mail.

Great thought! Just checked, but everything is set to mail:mail under /home/user-data/mail/mailboxes/…
Directory permissions are all: drwx------
Message file permissions are all: -rw-------

Using this as a hint, I picked my test user, and changed permissions to 766 down to the file level, still get a disconnect on directory open.