How do I completely disable the spam filter?

I’m pretty frustrated because I’ve been looking for work and a job interview email and it went to spam so I didn’t see it in time and I later got a notification that I was no longer being considered for this job because I didn’t respond to the previous email. I need all automated emails to go to my inbox by default. So how do I make it so absolutely nothing goes to spam unless it meets the criteria of a manually configured filter?

EDIT: I just put this rule at the bottom of my filter list, to move all messages to inbox by default http://imgur.com/a/tZXno hopefully this works as a quick and dirty fix

Your process works fine for single email user. I need a way by which can completely disable anti spam checking for all users in the server. Anyone can help?

I have tried this as well as using the global sieve. Emails still go into spam… The emails that I am receiving are from the same domain as the mail server as well. Driving me up the wall.

Try changing the /etc/default/spampd maxsize to 0, it’s on line 60:
ADDOPTS="--maxsize=0"