ERROR: HTTP ERROR 500 After Roundcube Login (2)

After an Ubuntu update it seems the Roundcube of my MiaB is broken.

I checked the Nginx error log and it’s giving me back this:

2020/06/12 13:41:23 [error] 13933#13933: *87 FastCGI sent in stderr: "PHP message: PHP 
Warning:  session_start(): Failed to read session data: user (path: /var/lib/php/sessions) in 
/usr/local/lib/roundcubemail/program/lib/Roundcube/rcube_session.php on line 136
PHP message: PHP Fatal error:  Uncaught Error: Undefined class constant 
Stack trace:
#0 /usr/local/lib/roundcubemail/program/lib/Roundcube/rcube_db.php(152): rcube_db_mysql- 
#1 /usr/local/lib/roundcubemail/program/lib/Roundcube/rcube_db.php(138): rcube_db- 
#2 /usr/local/lib/roundcubemail/program/lib/Roundcube/rcube_db.php(230): rcube_db- 
>dsn_connect(Array, 'w')
 #3 /usr/local/lib/roundcubemail/program/lib/Roundcube/rcube_db.php(416): 
rcube_db>db_connect('w', true)
#4 /usr/local/lib/roundcubemail/program/lib/Roundcube/rcube_db.php(379): rcube_db- 
>_query('SELECT `vars`, ...', 0, 0, Array)
#5 /usr/local/lib/roundcubemail/program/lib/Roundcube/session/db.php(106): rcube_db- 
>query('SELECT `vars`, ...', 'ivkv3u83phrc05p...')
#6 [internal function]: rcube_session_db->read('ivkv3u83phrc05p...')
#7 /usr/local/lib/roundcubemail/program/lib/Roundcube/rcube_session.php(136): session_sta" while 
reading response header from upstream, client:, server: box.domain.tld, request: 
"GET /mail/ HTTP/2.0", upstream: "fastcgi://unix:/var/run/php/php7.2-fpm.sock:", host: 

I already tried uncommenting the /usr/local/lib/roundcubemail/program/lib/Roundcube/db/mysql.php:149 rule but that doesn’t seem to work so before breaking more I brought that back in old state.

Does anyone have an idea what to do to make my Roundcube visible again?

P.s. I am already on 0.46.

Hi, I’m not sure if you are still experiencing this, but I have run into the same issue with version 0.52. Did you ever fix it?

Post: /mail and /admin Nginx page issues after upgrading 0.50 -> 0.52

Issue is still there. And I’m on 0.53 already. Still no fix.

Is there anything you have customized on your server? If you are using a VPS service, which ISP are you using?

No and TransIP is my VPS provider.

You can try posting in the MiaB slack channel or posting an issue to GitHub, but it seems like something either with your provider or your server, given that there are over 20,000 servers running MiaB, we would hear about this more than two times on the forum were it a common configuration bug with MiaB.

Can you confirm if you have php7.2-pdo-mysql installed?

1 Like
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'php7.2-mysql' instead of 'php7.2-pdo-mysql'
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 117 kB of archives.
After this operation, 449 kB of additional disk space will be used.
Get:1 bionic-updates/main amd64 php7.2-mysql amd64 7.2.24-0ubuntu0.18.04.7 [117 kB]
Fetched 117 kB in 0s (1,572 kB/s)
Selecting previously unselected package php7.2-mysql.
(Reading database ... 201504 files and directories currently installed.)
Preparing to unpack .../php7.2-mysql_7.2.24-0ubuntu0.18.04.7_amd64.deb ...
Unpacking php7.2-mysql (7.2.24-0ubuntu0.18.04.7) ...
Setting up php7.2-mysql (7.2.24-0ubuntu0.18.04.7) ...

Creating config file /etc/php/7.2/mods-available/mysqlnd.ini with new version

Creating config file /etc/php/7.2/mods-available/mysqli.ini with new version

Creating config file /etc/php/7.2/mods-available/pdo_mysql.ini with new version
Processing triggers for php7.2-fpm (7.2.24-0ubuntu0.18.04.7) ...

Seems it wasn’t.

1 Like

Installed it and now got this “beauty” of an error. chrome_QzbU4YjQy0

Did you try good ol’ sudo mailinabox?

OK. So…that’s on me, perhaps I should have said are you running phpX-pdo-mysql where X is whatever version of PHP you are currently running.

You should be good to undo that (apt uninstall php7.2-mysql) and then make sure you are running the relevant package for whatever version of php you ARE running. (It looks like it should be 7.2 based on the NGINX message, but if you’ve upgraded php, who knows?)

You may also need to re-run sudo maininabox

I don’t know anything about TransIP, but you might want to look through cat /etc/apt/sources.list and cat /etc/apt/sources.list.d/* to make sure the server is configured to pull Ubuntu project proxies (or just or for some PPAs). I’ve had the experience of an ISP default installed with their proxy server, which I found would sometimes have different package configurations than Ubuntu.

lol, so right after posting this my eye catches:

Uninstalled it. This is the current version I’m on:

PHP 7.2.24-0ubuntu0.18.04.7 (cli) (built: Oct 7 2020 15:24:25) ( NTS ) Copyright (c) 1997-2018 The PHP Group Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies with Zend OPcache v7.2.24-0ubuntu0.18.04.7, Copyright (c) 1999-2018, by Zend Technologies

The only big change I made was the upgrade from 14 to 18 back than.

OK, so the good news is that I gave you the right version in the first place. I’m wondering if you are missing other necessary plugins, too.

If you re-install that and then re-run sudo maininabox that SHOULD take care of the roundcube install.

1 Like