Emails we sent go most of the times to receiver Spam box

Hi there,

Has been few years now we are using MIAB and this problem has never been fixed. We believed the issue was related with the new server/IP but now the issue is becoming a bit annoying.

Can anyone help us understand why when we send an email (especially to new addresses) we realise that it ends in the receiver Spam Box?

Interested in having support as service - if interested PM us

Thank you in advance

Maybe … but sometimes there is no answer … especially if you are talking about Google, Micro$oft, or Verizon. Well, yeah that IS the answer…

Not quite certain what you are saying … but feel free to reach out to me in PM. I also may have a solution available. But first, I’d like to do some tests, so please let me know your MiaB hostname and your email domain name (if it is a different domain) when you PM me. :slight_smile:

Click on a users nickname, then the message box.

Ok … your first problem is that you are on a blacklist – that offers no path for removal.

More information about UCEPROTECTL3 can be found at their website:

Reason for listing - Your ISP AMAZON-02, US/AS16509 is UCEPROTECT-Level3 listed for hosting a total of 24314 abusers. See:

So, first and foremost, you can switch to another VPS provider which actually cares about their IP reputation and blocks spammers from their network.

Another option is to use a SMTP relay service. I have developed one for MiaB users in response to this issue. Using a PAID SMTP relay is a must as spammers have also ruined the reputation of the free levels of various SMTP relay services. If you want any information about it, please ask.

So, my initial conclusion without doing heavy research is that your IP reputation is what is causing your issue. You are using MiaB itself for DNS, so I would not think that there are any DNS issues.

1 Like

This what I see on my side. @alento can you try to send me a PM? …and I’ll see if I am allow to receive them…

Sent! You should get a notification at the top right where your … what is it called? icon? no … anyways in the top right of the screen!

i also have this issue, iv been told that there is some SPF records you can add that will eliminate this issue. i just havent got aorund to it yet.

If you are using MiaB as intended and it is serving it’s own DNS then you are covered. If you are using external DNS then you need to include ALL of the relevant entries in DNS.
If you are sending emails from a remote server, then you need to add something to the SPF. It all depends on your specific use case.

1 Like