DNS not resolving

I have installed Mail in a box a while ago on Digital Ocean. All was fine and everything worked great until my droplet on Digital Ocean needed to be resized because of hard drive space. After resizing my droplet I have been having DNS issues.

When i ping my server IP it pings but when i ping my server domain it cant resolve the host. I tried running the setup for mail in a box again still didn’t work. I checked all configurations and everything seems to be fine and bind is running and all services are too.

I tried entering my server IP into a browser and it returns back to my server host name but then stops saying host not found.

I need this resolved ASAP and get this thing working.

Howdy, did you use the MIAB recommended DNS server records check link?:
Found @ the MIAB guide?
Using some CLI (Bash, CMD, OSX console) can you issue a:
Men & Mice run their own resolver

Error I get:
domain does not have an IP Address (A) record

even though the A record is set in nsd zones.

Everything was working fine all configuration checks out.

dig output:
dig @ip my.domain.com
1 server found

Authority Section:
domain.com 1800 IN SOA my.domina.com

Using godaddy as domain registrar switch the ip’s there and the domain started pinging again but then when i switch back to mail in a box dns server it doesn’t work (ping request could not find host). So now I know godaddy is not the issue.

MIAB guide recommends:


I personally recommend Men & Mice since they maintain their own resolver.

Men & Mice does not return anything.

if i do (host mail.box.com) it resturns “not found 3 (NXDOMAIN)”

It seems as if there is no response from the name servers themselves.