DNS failure on Ubuntu 22.04


I try to install v61.1 on my Ubuntu 22.04 VPS and alsways ran into problems with DNS. Everytime the installer reaches “Installing nsd (DNS server)…” my /etc/resolv.conf ist set to nameserver and DNS resolving stopped working…

I could get around this with resetting resolv.conf for every step and install apt packages manually… but at step wget roundcube this won´t help… so I need a fix for my resolv.conf problem… why it alsways is set to and prevent from name resolving?

Mail in a Box install Bind9 as local dns resolver, which is why it is set to
I think I saw a number of people having issues at this step due to ipv6 being enabled or disabled. Did you change anything to the ipv6 settings of the box? Perhaps you can try enabling or disabling it.

thanks, it worked. but why I have to install bind9 manually, but NSD is installed by the installer?

I’m not sure what you did to make it work. It would be interesting if you could elaborate on the actions you have taken.
You should not have to install bind9, that is something the MiaB installer should do for you.

Did you install it on a fresh Ubuntu 22.04 VPS or on an already existing one with other things already running on it? I’m asking, because if you don’t start from a fresh installation, chances are high that you will experience issues like the one you are describing…

I installed MiaB on a fresh 22.04 VPS, thats why I wondered about the issues

I had exactly the same problem a few weeks ago. Fresh 22.04 VPS and name resolution failed after nsd was installed by the MiaB installer. From memory the solution was either to install bind9 or enable it via sysctl. I’m sorry I don’t recall which one it was. It was unrelated to IPV6. bind9 simply wasn’t running. Perhaps it’s something that some VPS providers configure differently to the default 22.04 installation and the installer isn’t catching it?

I meant systemctl not sysctl, i.e. systemctl enable bind9.

Hello @superfun1, I suggest the solution from:

In summary:

  1. Fresh Ubuntu 22.04.01 VPS deployment.
  2. As root:
    apt update
    apt install bind9
    nano /etc/bind/named.conf.options
  3. Change “dnssec-validation auto” to “dnssec-validation yes”, then exit & save file.
  4. Install MIAB v60.1
  5. If it worked, you may optionally try to revert to "dnssec-validation auto” and reboot. END.
  6. If it did not work, start again fresh from step 1 and try other option value at step 3 (i.e. try “auto” or “no”).

For me, it worked with “no” at step 3. Tell me if it works for you, good luck.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.