DNS errors please help

I set up my server and mail works and SSL works but I get these errors
Local DNS (bind9) is not running (port 53).
Local DNS Control (bind9/rndc) is not running (port 953).

What am I doing wrong/what do I need to do? I am loving this software great work guys :smile:

Does this error persist across reboots?

Yes I have rebooted numerous times.

Try to “sudo service bind9 stop” and “sudo service bind9 start” and see what happens :wink:
If this does not work, try to re-run the setup with “sudo mailinabox”.

Which provider are you using?

Okay I did that and it gave me no errors or confirmations for restarting bind9, and rerunning the mailinabox ran fine without problems. It didn’t fix the problem. I am using impactvps.

sudo netstat -plnt | grep ':53'

What results?

tcp 0 0 myip:53* LISTEN 10155/named
tcp 0 0* LISTEN 10155/named
tcp 0 0* LISTEN 10155/named
tcp6 0 0 :::53 :::* LISTEN 10155/named

If your ports are active and mail is flowing then it’s a UI bug.

Are you running Mail-in-a-Box on a clean and fresh Ubuntu 14.04 LTS Image?
Have you already tried to reset the whole machine, or creating a new one? Same bugs?
Can anybody reproduce this with ImpactVPS?

Hello Ozfer,

There is an issue with the bind9 package.

Type these in order in a root shell:
/etc/init.d/bind9.dpkg-dist start
update-rc.d bind9.dpkg-dist defaults
update-rc.d bind9.dpkg-dist enable

Bind9 should start working and would start upon reboots. The Ubuntu packaging probably made a mistake. They made the bind9 script an empty script that returns 0 for all cases, while leaving the real script at bind9.dpkg-dist.

I too have the same issue. Fixed it the way I mentioned above.

Have a great day! :slight_smile:


Hmm that get rid of one of the errors. I still seem to be getting. I don’t know if it really matters as I think i’m not using the DNS functionality of this. At least getting rid of the other errors allowed for me to see the other check marks. Should the firewall not be blocking for 953 because it seems to be blocking it?

Local DNS Control (bind9/rndc) is not running (port 953).

In that case try this in a root shell:

rm /etc/init.d/bind9
apt-get purge bind9
apt-get install bind9
update-rc.d bind9 enable

reboot your VPS, wait for 10 mins to stabilize. Then connect and check.

I think you may create problems in the future with that solution. The only reason I can think of that you have that file is during an update, or upgrade, of bind you were asked to accept the changes, (optionally compare a diff…) and you said No when you should have said yes.

Undo what you did and “mv /etc/init.d/bind9.dpkg-dist /etc/init.d/bind9”.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.