Did Gmail change something recently?

I run MIAB for a while now (v56, just updated to v57a), including sending email to Gmail users regularly. Today, I got two failure reports, that complain my server (Linode) does not have a PTR record, but when I check at Linode the server already has reverse DNS set. Looking at mxtoolbox.com I see two errors, one is the scammy UCEPROTECTL3 and the other is about the name servers being on the same subnet. What can I do to fix this?

The nameservers being on the same subnet would not be related to the PTR record issue as that is managed by Linode. My guess is Linode coincidentally having some sort of issue responding to requests. This should be checked from somewhere outside of Linode’s network.

You can add a secondary DNS server. Users have reported using puck.nether.net and dns.he.net.

There are instructions at the bottom of the ‘Custom DNS’ page in the dashboard are some instructions on adding a secondary name server and one of the other moderators created this tutorial for puck.nether.net:

Thank you! I will have a look. Hopefully it is indeed just a temporary Linode issue.

This could simply be a temporary failure in dns resolution. I would ignore it unless it is repetitive.

Email sys-admins do not take mxtoolbox.com seriously as they are gearing you towards purchasing something from them.

You seemingly already know about UCEPROTECTL3 and name servers on the same subnet is really just a warning message. Though I would highly recommend that you do indeed enable secondary DNS to prevent a single point of failure or loss of email in case something were to happen with your VPS.

Thanks for all the input.

I did enable the secondary DNS.

The error still shows some 24 hours later. But when I tried to send the email via a different provider, the same error message showed. According to whois, that email provider uses XS4ALL servers, so I guess it is a wider issue.

When adding the secondary DNS, I was wondering if subdomains (custom DNS records) would be mirrored there as well? For example at puck.nether I could not enter abc.test.com, only test.com. So does puck.nether act as a secondary DNS for abc.test.com as well? Or is my MIAB the only DNS server for that subdomain after all?

The secondary server will serve all the records MiaB is configured to serve and will be updated automatically.

1 Like