Can't install php5-common

Setting up php5-common (5.5.9+dfsg-1ubuntu4.21) ... dpkg: error processing package php5-common (--configure): subprocess installed post-installation script returned error exit status 10 Errors were encountered while processing: php5-common E: Sub-process /usr/bin/dpkg returned an error code (1)

Having trouble trying to upgrade to 0.23. Had some issues with updates not working at all for a while, and I managed to fix that but in the process have created a problem above where I can’t install php5-common, and therefore I can’t install the MiaB upgrade to 0.23 (and my MiaB is mostly broken).

I’ve tried:
apt-get clean
apt-get install -f
apt-get autoremove
apt-get purge php5-common
apt-get upgrade

Can someone give me a hint? Nothing I try gets php5-common to re-install.

My recommendation is to backup the /home/user-data stuff, reinstall the machine to a fresh 14.04 LTS, restore the /home/user-data and then install mail-in-a-box anew. This will keep all of the mail-in-a-box related things the same. Anything you’ve done manually, though, will be lost.

Trying this… but now I’ve got a problem with OwnCloud/NextCloud not installing due to my existing version/data being too old. I don’t know how to step-through versions for OwnCloud or MiaB.

what version of mail-in-a-box did you previously have?

0.19 from memory. Unfortunately it won’t let it upgrade to the new one because it’s two versions of OwnCloud/NextCloud behind.

You can use to get older releases. Extract it to /root/mailinabox and then run mailinabox. You probably need to run it one by one for 0.20, 0.21c, 0.22 and 0.23a. Good luck! :slight_smile:

Installing 0.19 again and then upgrading straight to the latest should work fine.

Not quite working:

"fatal: Not a git repository (or any of the parent directories): .git
bash: line 42: [: v0.23a: unary operator expected"

The re-install of the old version is fine, and the backup restore worked, running the:

curl -s | sudo bash

Gives the above result. I assume this is a problem to do with the manual install of the old one?

I’m not quite sure what you’re saying. v0.19 installed fine using the method I pointed out? And now you can’t run that curl command successfully to upgrade further than that? In that case you can delete /root/mailinabox again and then run the curl command.

Cheers hachre, I suspected that was the way to go but I didn’t want to break it and have to start over. Uploading backups takes forever!

All working now, on the latest. Thanks for all your help.

1 Like