Can't connect to my server. HELP!

Hi Everyone,
I’m currently experiencing the most bizarre issue with my mail MIAB server. I can’t connect to it through SSH, SSH refuses the connection on port 22.

I also can’t connect the the admin or webmail pages via any web browser. I am hosting on Digital Ocean and the only way I can currently connect is via their web browser based console window, which i’m guessing must be some sort of web based KVM client to the QEMU VPS. I have 4 virtual servers hosted in the SIngapore datacenter on Digital Ocean and the others are accessible as normal. I can connect to them with SSH and to the web pages hosted on them.

I have tried disabling the UFW firewall temporarily to make sure it wasn’t a firewall issue, that didn’t solve the issue. I have checked my DNS records with my DNS provider, Crazy Domains and they all look normal. If anyone has any ideas please help. It has been down for 2 days now. I have rebooted many times. I’m pretty sure the servers are all running like nginx, sshd etc. But i’m not sure which commands I can use to check them.

See this document for a full analysis of the server from

Have you tried running the MiaB install script?

That won’t delete any data will it? As I have no way to get the backup data off the server

The only thing it would delete is any custom configurations.

That doesn’t work. I just logged into the console as my user and issued the command for the install script and it did nothing. It just dumped me back to the command line. This also happened when I did su root and ran the command as root (deleting the sudo part before bash). This also did nothing and dumped me back to the command line. HELP!!!

I haven’t customised it in any way. I login every few days to run updates and make sure it’s running ok. I have not changed any configs manually or customised it in any way. It has simply stopped responding to me. If you look at the traceroute in the doc I attached on dropbox, you will see a few missed hops. I am in Australia, no VPN in use. Could there be network issues between me and Singapore? Can someone outside Australia / Sydney please try to access the server at and let me know if you can access it?

No problem with any of these from here … sounds like your IP is blocked by fail2ban.

1 Like

how can i fix it? I can login via the console and have root access there.

Come to the Slack

I find that hard to believe since I am the only person with access to this server. The last time I logged in via SSH, it worked fine.

If you fail to type the password correctly 3 times it bans you for a few minutes.
Get your IP using then:


fail2ban-client set sshd unbanip IPADDRESSHERE
1 Like

Just an update to this issue … OP and I troubleshot for an hour last night.

It seems to be another Digital Ocean issue. OP is not blocked by ufw, fail2ban, or DO firewall, but is unable to reach his server from multiple IP’s within his country. Yet the rest of the world can reach his MiaB just fine. No, OP is not in China! :stuck_out_tongue:

Did he actually contact DO and have them check if he is blocked at their level - I know you say he is not blocked by a DO firewall but DO has their own firewall beyond the droplet assigned firewall you see in your DO control panel

I can’t confirm or deny - but this is the 2nd case of this in two months with DO that I have encountered. They claim no blocks.

I know with brand new DO accounts you have to specifically request ports to be opened up

Ports are open. I can access all parts of his server just fine. Problem is, he cannot. Not from his home network, not from his work network, not from his mobile network.

Oh, and he can access his other DO droplets just fine as well.

Op made a snapshot and restored it to a different droplet, still no love. So, that makes this all the more confusing - as it somehow seems to be MiaB related. Sadly, I haven’t had an update from @gman1979 in a couple of days.

I wonder if this droplet’s location (country) is different from the rest? Maybe that’s what’s going on?

Nope, all in the same data center.

@gman1979 Have you tried a traceroute from your ISP/network or try to connect via a VPN? Your ISP (or someone in-between) could be blocking your connection…

I ran in to this with WISP one time.