Can't Access Box: Connection to Storage Server Failed After Upgrade

Hey guys! I am have major issues with my mailinabox (and this is important because I need access to this email). I just finished upgrading to v57a, and everything is well, except when I try to login to my email server, it says “Connection to Storage Server Failed”. I have tried everything between rerunning sudo mailinabox, to sudo reboot. The control panel shows nothing out of the ordinary (everything is green) so I am stuck and was hoping maybe you can help. This system was working perfectly before I stupidly decided to upgrade, and I thought my host was performing automatic backups, but turns out it wasn’t. There was absolutely nothing I changed, what is going on?

Do you mean the message is being printed when you try to log into Roundcube?

Yes, that is correct. Attached should be the screenshot I got when attempting to login image

Are you able to access mail with a mail client?

Very interesting! When I first refreshed on my phone, it was taking a long time to load so I thought it was erroring on there as well, but I sent myself a test email and it came through, so yes! I am able to access it on my phone (which I assume is a “mail client”)

Have you tried logging in with a different browser?

Just tried logging on via Firefox (previously: Brave) and it is showing the same error when attempting to log on.

Did you make any changes to Rouncube or anything else in MiaB?

No, I am 99% confident I did not. I just upgraded the MiaB to the latest version and then rebooted the server.

Did you send the test email from a different mail server?

Yes. I sent the test message through Gmail.

Are there any related entries in /var/log/nginx/access.log or /var/log/nginx/error.log?

Yes, there are related entries to both. (I’ve hidden some parts of the logs for privacy)


[17/Aug/2022:15:12:58 -0400] "GET /mail/plugins/persistent_login/persistent_login.css?s=1660736091 HTTP/2.0" 304 0 "https://********.com/mail/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/103.0.5060.134 Safari/537.36"
[17/Aug/2022:15:13:22 -0400] "POST /mail/?_task=login HTTP/2.0" 401 6000 "" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/103.0.5060.134 Safari/537.36"

I think this is related but in /var/log/nginc/error.log

2022/08/17 15:12:57 [error] 8468#8468: connect() to [2600:1400:d::17db:5c11]:80 failed (101: Network is unreachable) while requesting certificate status, responder:, peer: [2600:1400:d::17db:5c11]:80, certificate: "/home/user-data/ssl/********.com-20221028-231db80b.pem"

I don’t know if this is relevant but I have been doing some digging myself and found that entries are being sent over to /var/log/roundcubemail/errors.log, this seems to happen every time I attempt to login:

[17-Aug-2022 15:22:03 -0400]: <g8shspf4> IMAP Error: Login failed for jtwooton@********.com against localhost from ***.**.***.**. Could not connect to ssl://localhost:993: Connection timed out in /usr/local/lib/roundcubemail/program/lib/Roundcube/rcube_imap.php on line 211 (POST /mail/?_task=login&_action=login)
[17-Aug-2022 15:23:19 America/New_York] PHP Warning:  stream_socket_client(): unable to connect to ssl://localhost:993 (Connection timed out) in /usr/local/lib/roundcubemail/program/lib/Roundcube/rcube_imap_generic.php on line 1060
[17-Aug-2022 15:23:19 -0400]: <d9u5cc0e> IMAP Error: Login failed for jtwooton@********.com against localhost from ***.**.***.**. Could not connect to ssl://localhost:993: Connection timed out in /usr/local/lib/roundcubemail/program/lib/Roundcube/rcube_imap.php on line 211 (POST /mail/?_task=login&_action=login)

From which Mail-in-a-Box version did you upgrade? You are using Ubuntu 18.04?

Yes, Ubuntu 18.04.6 LTS

As it pertains to where I upgraded from, I don’t remember but I think it was 2 versions ago, from 55(?) to 57a

Update on this: I ended up nuking the server and starting fresh, which seemed to have helped. However, after rebooting for an update that the server got, we’re back at square one with this. I followed the setup instructions perfectly. This has got to be a bug somewhere considering I just started fresh and still having this issue.

A bug like this for a release out this long I expect would draw at least 1000 posts here in the support forums. It’s likely something specific to your install.

What is the hosting environment?

Hmm true. I’m actually starting to become convinced that it’s the hosting itself, I was using GalaxyGate and it has been working perfectly fine until 2 days ago. Rebooting has failed multiple times. I will probably end up switching hosts, setting things up again, restoring a backup, and then see how things go from there. I think that would be quicker if successful than further diagnosing what’s going on. I don’t have much time to deal with this because of school and work (not to mention that the IP block that GG has does not have a good reputation), if something continues to go wrong I will post here if it’s the same issue or find a different solution.

The hosting environment is Ubuntu 18.04.6 LTS (GNU/Linux 4.15.0-191-generic x86_64), I think that’s what you’re asking?

Sorry, I mean all of the stuff around the system. For example, you could have it on a local private network on its own hardware behind a network gateway, you could have it in your own hypervisor, you could have in a Linux container, etc. These things can cause various different problems that are not obvious when we are only discussing the system, itself.

Oh! Okay, it’s hosted on GalaxyGate. From what I understand from them, they use virtualization to generate servers. My current speculation is that something is going on with their virtualization that is causing these issues. (I’ve had issues with it in the past), it is 1 GB RAM.

If that’s not what you were asking for, whoops lol