Cannot access via

I just tried to access my box via: but I get a time out error (mozilla firefox is the browser).
Nevertheless I can access it via: (and mail too). ANd I just checek - I can send and receive mail.
Yet in my mac, the mail account appear with the warning triangle, and I cannot access it via
The systemcheck page shows everything is OK - certificates included.
Please, can anyone help me understand what is happening and how could I solve it?

Update I do not understand: I just was able to access mi Miab thorugh
And I did not do anything. At all.
How is this possible? Why does it happen? Is there any log I could look into, and try to understand something?
This is a bit twilight zone for me…

IIRC you are hosting your MiaB at home?

1 Like

yes, on an relatively old Acer laptop. and today is working perfectly.
I suppose it has to do with my mac, where from I was trying to access my box (and today, from the same mac book pro I accessed it without problem).

I am of the opinion that running MiaB on a local network rather than a VPS is completely unreliable unreasonable unless you have a solid background in networking.

There is a reason that MiaB does not support that configuration. ETA: And the reason is that MiaB was created with a specific target audience, and this use case is not within that audience.

Of course, anyone is free to do as they wish, but the volunteers who offer support to this project cannot support “unsupported modifications”.

… on a local network rather than a VPS is completely unreliable

I think that statement is a bit too strong. I’m running MIAB from home and am very happy with it. “At home” is not so much unsupported, as it is exactly the same config as from someone else’s (virtual) computer at a data centre.

However, a data centre server is normally (but not always) connected directly and completely to the internet. Your home server is behind a router with some filtering (aka “modem”) so you have to ensure that all required traffic gets to & from your server. The traffic that must get to and from your server is ports 22, 25, 53, 80, 443, 465, 587, 993, 995, 4190.

Many domestic ISPs, and some data centres, block traffic on port 25. That port is vital, so no port 25 means no direct email for you.

If you’re not comfortable opening up the required ports through your router/modem, and checking that your ISP will let port 25 through, then perhaps MIAB at home isn’t for you. But if you’ve got the knowledge to do it, or are happy to learn, try MIAB at home.

(Most usual issues have been covered in old forum posts, search is your friend. Your initial issue sounds like a DNS propagation issue - quite common, covered in the forum and installs notes.)

You’re right, so I will edit my comment to qualify that statement.

There are indeed several people successfully running MiaB “at home”, yourself included, but to do so requires an extreme deep knowledge of networking which the average non technical user (the target audience of MiaB) does not have.

With limited, and community based only, support options available it is strongly discouraged to go against the norm use case defined by MiaB. Of course, anyone is free to do as they wish, but we cannot offer support for a non-standard configuration. Which is the case here.

THank you both, for your interest.
I must say, it was not my intention to start such a debate. After all, I am very pleased with Miab on my local network, I know how to open the ports in my router, and right now everything is working just perfect.
It was my understanding that a VPS is, simplifying at the extreme the idea, nothing else but another computer, with a “slot” of hard disk (ssd) allocated to you as long as you pay for it (of course, inlcuding some other resources). But, for my personal use, it isn’t worthy paying a VPS - at least for now.
Nevertheless, the error message that originated this thread, I still think it was because of a momentanous error from my mac (as a starting point - hours later, just as I said, it worked perfectly - and still does eversince).
Yet, I am still lacking of the needed “extreme deep knowledge of networking” (@alento - you are totally right in your statements, by the way) - that’s why I recurr to the help provided by generous people in this forum (and thank god not arrogant ones, as I’ve met along other “places”).
So, indeed, thanks again for your interest and help. It is very much appreciated.

This topic was automatically closed 40 days after the last reply. New replies are no longer allowed.