Bind9 stops automatically

Hi,
My MIAB server’s bind9 stops automatically. And obviously when it happens leads to failure of email communication.
My server has 1 GB RAM. Do you think that could be an issue? At this time I could see free RAM is 600 MB.
How to debug?
Thank you.

Have you made any modifications from how MiaB configured the server?

What version of MiaB are you on?

Is there anything in the logs?

  1. No, not at all
  2. v0.52
  3. There are lots of logs. But I have no idea which log to share. Can you point me the direction.

Usually issues like this will show up in /var/log/syslog, though I have to admit I’ve not had issues with bind.

How do you know that bind9 stops?

Also, is there a reason you have not updated to .53a?

Is there any regularity to this?

No, not at all.

The next time it happens do service bind9 status from the command line and share the result,

Is your system clock reasonably accurate? If it’s way off, you’ll have trouble resolving names. This won’t stop the service, but will prevent it resolving. (I had this problem with a Raspberry Pi, which had no internal RTC and would wake up with an old date/time.)

Usually, I receive system checks mail where it mentions bind9 not running.
Then, I login to the server and restart. Fortunately, it hasn’t stopped in the last 9 days.
I just updated the MIAB to 0.53a.

No regularity.
Yes, I will share the logs and the status.

I believe clock settings are accurate. Usually MIAB asks for time zone during installation itself. I don’t have trouble resolving names. I am using external DNS and website is running on main domain.