Backups clog storage

Good afternoon ! please help! I have a problem with the backup. I recently discovered that my server’s memory is clogging up and mail services stop working. I tried to delete them manually but they are created again and the old ones are not deleted. Please tell me where to dig and what to check?!

Backup Status page:
Backups are stored on this machine’s own hard disk. You are responsible for periodically using SFTP (FTP over SSH) to copy the backup files from /home/user-data/backup/encrypted to a safe location. These files are encrypted, so they are safe to store anywhere.

Separately copy the encryption password from /home/user-data/backup/secret_key.txt to a safe and secure location. You will need this file to decrypt backup files.

Maybe copy them to another device/server then remove them from /home/user-data/backup/encrypted - the next time backup runs it will create a full backup - perhaps you could setup a cron job to archive them off the MIAB server then delete the on-server files leaving you the space.

1 Like

Storing backups on the server itself is not really a good idea. Backups should be stored on a different location. The easiest way is to use rsync to copy the backup to a linux server or NAS. I store mine on a Synology NAS and use rsync and the public key so it is a safe process. If you do this backup will be incremental and the full backup will be cycled. The space you will need locally is going to be about 45GiB in your case.

1 Like

my backups are copied to an external server by sftp
I tried manually deleting all backups, the folder cashe and running the backup manually
sudo management/
old backups are not deleted as before ((((

can anyone help me with a script that will delete all files older than 2 days from this folder?

Can you not use the rsync option instead of copying via sftp? In this case there is no need to delete anything.

1 Like


The first thing you need to do is to reclaim some empty space:

Then I am curious to know why you are keeping a second backup with multiple copies on the server at /root/backup/mailbox? Are you using some utility to create this backup?

1 Like

yes, I have a script that copies backup files to this directory, I already found an error and fixed it, thanks everyone for the help.
Has anyone tried a hetzner?