Backup is missing several domain folders and appears corrupt

I use local backups and have a cronjob to SCP them to a separate storage server. A user recently reported to me they are missing emails from before 8th September. I used:

sudo -E duplicity restore -t 10D --file-to-restore mail/mailboxes/domain/account file:///path/to/encrypted output-10daysago

Yet this folder does not even contain the domain folder. I then tried a few other dates and can not find a single backup date which contains the domain folder in question. I tried a simple:

sudo -E duplicity restore --file-to-restore mail/mailboxes/domain/account file:///path/to/encrypted output-current

and this results in the following error:

Local and Remote metadata are synchronized, no sync needed.
Last full backup date: Thu Sep 14 03:00:03 2017
Traceback (most recent call last):
  File "/usr/local/bin/duplicity", line 1548, in <module>
  File "/usr/local/bin/duplicity", line 1534, in with_tempdir
  File "/usr/local/bin/duplicity", line 1383, in main
  File "/usr/local/bin/duplicity", line 1462, in do_backup
  File "/usr/local/bin/duplicity", line 729, in restore
  File "/usr/local/Cellar/duplicity/0.7.14_1/libexec/lib/python2.7/site-packages/duplicity/", line 560, in Write_ROPaths
    ITR(ropath.index, ropath)
  File "/usr/local/Cellar/duplicity/0.7.14_1/libexec/lib/python2.7/site-packages/duplicity/", line 347, in __call__
    self.process_w_branch(index, branch, args)
  File "/usr/local/Cellar/duplicity/0.7.14_1/libexec/lib/python2.7/site-packages/duplicity/", line 302, in process_w_branch
    branch.start_process, args)
  File "/usr/local/Cellar/duplicity/0.7.14_1/libexec/lib/python2.7/site-packages/duplicity/", line 38, in check_common_error
    return function(*args)
  File "/usr/local/Cellar/duplicity/0.7.14_1/libexec/lib/python2.7/site-packages/duplicity/", line 593, in start_process
    assert index == (), index
AssertionError: ('mail', 'mailboxes', '<<<domain here>', '<<<account here>>>', '.archive')

Any help on getting my backups back up to scratch would be appreciated.


Any help greatly appreciated with this. Thanks!