Backup after update - second issue

After updating to the latest version i hab trouble with the backup script. after downgrading duplicity to a 1.2.x Version i got a problem with the boto3 python lib:

BackendException: Could not initialize backend: No module named ‘boto’
Something is wrong with the backup: ERROR 23 BackendException
. BackendException: Could not initialize backend: No module named ‘boto’

Starting python from the command line and importing boto3 works. Testing the backup script manually shows the error.

any ideas?

Kind regards,


1 Like

I am having the exact same problem, like you I have downgraded duplicity and this morning I found the same message (my backup runs overnight).

For now I have tried

pip install boto

Hopefully it works, I will report back after my next scheduled backup.

Hi mastazi,

the backup script imports boto3. Installing boto fixes the ERROR23 but i get some new errors when i start the from the console manually. → ERROR 30 gaierror
Looks like a connection error to AWS S3.

Does the manual backup work or you?

Here is my error log:

Something is wrong with the backup: ERROR 30 gaierror
. Traceback (innermost last):
.   File "/usr/bin/duplicity", line 92, in <module>
.     with_tempdir(main)
.   File "/usr/bin/duplicity", line 75, in with_tempdir
.     fn()
.   File "/usr/lib/python3/dist-packages/duplicity/", line 1555, in main
.     action = commandline.ProcessCommandLine(sys.argv[1:])
.   File "/usr/lib/python3/dist-packages/duplicity/", line 1223, in ProcessCommandLine
.     config.backend = backend.get_backend(args[0])
.   File "/usr/lib/python3/dist-packages/duplicity/", line 223, in get_backend
.     obj = get_backend_object(url_string)
.   File "/usr/lib/python3/dist-packages/duplicity/", line 209, in get_backend_object
.     return factory(pu)
.   File "/usr/lib/python3/dist-packages/duplicity/backends/", line 174, in __init__
.     self.resetConnection()
.   File "/usr/lib/python3/dist-packages/duplicity/backends/", line 199, in resetConnection
.     self.bucket = self.conn.create_bucket(self.bucket_name,
.   File "/usr/local/lib/python3.10/dist-packages/boto/s3/", line 618, in create_bucket
.     response = self.make_request(

Thanks for your help and kind regards,


Hi Maurice,
unfortunately I’m seeing exactly your same issue (“gaierror”).

I understand what the error is about, see here python - What does this socket.gaierror mean? - Stack Overflow

but, this time, I don’t know how to fix it.

I’m going to look into downgrading to the previous version until it’s fixed. Could someone please share a link to instructions on how to downgrade mailinabox? Thank you!

Thanks for your feedback! With downgrading MIAB i will not be able to help you …
cu & best regards,


Re-running the mailinabox installer (curl -s | sudo bash) fixed it for me.

Hi hrunk,

did you set the duplicity update on hold before you re-installed the MIAB update?


My setup works again!

After unmarking duplicity, updating to version 1.2.x and the restart the installation script as suggested by @hrunk my backup works again. Thanks for all of your help.

@mastazi Does it work for you too?


Thank you @MuckiSG for the heads up! I’m traveling until tomorrow and can’t ssh into my server (so I can’t unmark Duplicity) but will report back when I’m back home!

Hope the solution helps you aswell!

So does this mean that the Duplicity updated version now works with MIAB? Or are we still holding it at 1.2?

Hi @Infidelus ,

i rolled back to version 0.8.21-1build1 and had this version on hold. Now i have version 1.2.3 and nothing marked on hold.

hope it helps, Maurice

1 Like

Duplicity rolled their v2 buggy release back to v1.2 pretty quickly and v1.2 works. So if you ‘update’ Duplicity you will get 1.2 now

1 Like

Thanks both. I’ve removed the hold on Duplicity and it’s 1.2 now.

Hi @MuckiSG and everyone else, after unmarking Duplicity

sudo apt-mark unhold duplicity

and then updating it

sudo apt update && sudo apt upgrade

Everything is back to working for me! :smile:

Seems like the new version (v2.1) which replaced v2.0 has the same issue and I appear to be unable to source 1.2.3 as it’s not found as an available release to install.

Have had no choice but to install 0.8.21

I’m back to the Error 23…No module named boto error now from the Backup status screen or Error 30 gaierror from a manual run

Same for me :frowning: but I could downgrade to 0.8.21 again :slight_smile:

I suggest everyone do sudo apt-mark hold duplicity immediately, or if your normal updates have already run and broken things, do:

sudo apt install duplicity=0.8.21-1build1
sudo apt-mark hold duplicity

Yep, broken again this morning after the update to 2.1.0. Rolled back to 0.8.21 again and put Duplicity back on hold.

OK, thx for warning. Set my 1.2.3 Version on hold for no updates …

@MuckiSG and everyone else, new mailinabox v64 fixes this issue with duplicity, so you can update your Mailinabox and then unhold duplicity. See release notes here Release v64: Version 64 (September 2, 2023) · mail-in-a-box/mailinabox · GitHub