Amazon S3 Backup

Just messing around with Amazon S3 backup but everytime i imput my information it says OK then comes up with this message.

Something is wrong with the backup: ERROR 23 BackendException
. BackendException: Could not initialize backend: No module named boto

This is a new box setup so i have not changed anything

try this command:
pip install boto

What’s the output you see?

Requirement already satisfied: boto in /usr/local/lib/python3.4/dist-packages

duplicity is python 2.7, not python 3, so you’ll need boto installed for python 2.7

The setup should have done that for you.

Since phython is already installed how do i install 2.7?

I had this issue…

This worked for me.

“apt-get install python-boto”

Ditto. Had the exact same issue on a clean install of 0.21c. Installing python-boto fixed it.

I had the same issues as above. I also found that deleting or renaming your S3 bucket will trigger the same error message.

After much digging around I finally found the issue, as I am using Frankfurt for my S3 backup.
The problem is that when installing Mailinabox on a new box the BOTO package is correctly installed for Python 3, but not for Python 2 that Duplicity uses.
Installing it from the repository does not solve the problem for me as an old version of BOTO is provided, so to fix the problem I proceeded in the following way:
As Root:

apt-get purge python-boto

this will remove the ubuntu-provided old boto if you tried the solution from damowhite232

git clone git://
cd boto
python install

This will install the last boto release in Python 2.7 allowing to backup and restore from S3 Frankfurt

EDIT: Thanks to nstanke on Github, there’s a cleaner solution / workaround:

sudo pip2 install --upgrade boto

so there’s no need to pull boto from git