All emails are going to the spam folder on Gmail and Outlook


I set up a server on Digital Ocean to run a mail-in-a-box server. I’ve managed to set up everything successfully and the status page shows everything is green. Nonetheless, all emails sent to Gmail accounts are marked as SPAM.

I’ve been checking the DNS records, but they all seem to be fine. also shows a score of 10/10. I’ve been looking at all sorts of threads, but I can’t quite figure out whats wrong. Some people have been complaining about Digital Ocean IPs but the IP isn’t blacklisted anywhere…

Here are the headers from one of the emails that was marked as spam:

Delivered-To: carl****** Received: by with SMTP id n8csp472281ywh; Fri, 16 Dec 2016 06:02:55 -0800 (PST) X-Received: by with SMTP id 1mr3584102wmv.133.1481896975022; Fri, 16 Dec 2016 06:02:55 -0800 (PST) Return-Path: <carl******@***.ch> Received: from box.***.ch (box.***.ch. []) by with ESMTPS id x130si3478127wmg.27.2016. for <carl*******> (version=TLS1_2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128); Fri, 16 Dec 2016 06:02:54 -0800 (PST) Received-SPF: pass ( domain of carl*******@***.ch designates as permitted sender) client-ip=; Authentication-Results:; dkim=pass header.i=@***.ch; spf=pass ( domain of carl********@***.ch designates as permitted sender) smtp.mailfrom=carl*****@***.ch; dmarc=pass (p=QUARANTINE dis=NONE) header.from=***.ch Received: from [IPv6:2001:67c:10ec:52c6:8000::e2c] (unknown [IPv6:2001:67c:10ec:52c6:8000::e2c]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by box.***.ch (Postfix) with ESMTPSA id 291E6DFEF9 for <carl******>; Fri, 16 Dec 2016 15:02:54 +0100 (CET) Authentication-Results: box.***.ch; dmarc=fail header.from=***.ch DKIM-Signature: v=1; a=rsa-sha256; c=simple/simple; d=***.ch; s=mail; t=1481896974; bh=BVnEAHWeMq5NbsEKqWiu7T3IhFCt5tdX2hF5hxtImpU=; h=From:Subject:Date:References:To:In-Reply-To:From; b=iBznR1wvvcQ3Z5YWibrrw3yAYEkVpz2R7ME1c7tu8ZEPlIACJHkgKBE33Qsu5yYrt tlyadpRb+8dJiXko0HtTpox62+7vtkq01c0/s+4w2azp84eJcF6j+t8n2YkG+btJOw M/GL8H7EzbpI/3ONNGl/faCGh8p6DlfMwk7dEOYFcvHhZW6uKeSY51ypWuR104WKGk BmYxYoXt3D41YrFN72nr+xtkZ4T1Z+K3BA5J2plXE9DLA6qlIae5A6LVG6RziWrqoS +sAEJIh0PxXSLG9an4HiWEh8JFcoIYG95pXOe8QF3herJo6h94tLVine/XY9ubj05r isIx6bihDePgw==

Thanks for any help! I’m a bit stumped…

Google blocked you IP block due to spam. There is nothing you can do about this other than moving to an ISP (or VPS) hosting provider that is not blocked by

Thanks for the reply! :slight_smile: That’s unfortunate. But how do you know if Google is blocking the IP? Also do you have a recommendation for a hosting provider? Would Amazon be better?

Google is most likely not blocking your IP Specifically, but the IP BLOCK it is on (123.123.456.5-123.123.456.10 as an example.)

Amazon is generally NOT blocked, but a quick call to google’s support would give you an answer. Requesting a new ip from your current VPS provider might help as well.

1 Like

If you are not using the MIAB DNS then putting in the SPF and DMARC data in TXT records. That got me out of the spam bucket with Gmail.

Maybe you also have to do it on domains that are using MIAB DNS. I only host the required (admin user) email box on MIAB. All my other domains I use External DNS records at the registry or the web host level. Since I never send email out of my admin email I don’t know if you need to do it or not for the admin user.

These resources could help you: (you will need a google account for this) (you will need a live account for this)

Hi! Thanks for the replies. Unfortunately nothing worked. I’ve now solved the issue using a workaround. I tried hosting the server on Digital Ocean, Amazon EC2 and Vultr. It does seem to be the case, that the IPs from all these services are banned by Google. So I’ve decided to host the Mail-in-a-box server on an Amazon EC2 instance and relay all outgoing mail through Amazon SES. Now all emails get accepted by Google! :slight_smile: In case anybody wants to do the same, this is what I did:

  1. Verify add and verify the domain to Amazon SES, by adding the TXT record they give you in the Mail-in-a-Box admin panel under System > Custom DNS.
  2. Add the CNAME records to enable DKIM as well. Do not forget to put a . at the end of the domains that Amazon give you to use as the values.
  3. Override the SPF record by adding a TXT record for the domain with the value “v=spf1 mx -all”. This allows Amazon SES to send emails from your domain.
  4. Now setup Postfix to relay emails through Amazon SES. Follow the steps in this guide:
  5. Finally if you are sandboxed, you will need to Submit a Sending Limits Increase Request to allow you to send emails to unverified addresses:
  6. If you are hosting the Mail-in-a-Box on an EC2 instance, you will also need to complete this request:

That’s it. Obviously not the best solution, but it works well! :slight_smile:

Are you sure? I sincerely doubt that Gmail has ‘banned’ all of the IPs from the major cloud server companies. There has to be something else going on here. But I’m new to this ‘game’ so maybe you are right. But if you are, there would be zillions of posts about it both here and on other boards/sites.

I’m not sure, but I tried with another domain and same issue. I think it makes sense that EC2 instances would be used for SPAM a lot, so I guess it’s just those IPs that are blocked.

Maybe try Linode?

But as I say… it is hard for me to believe that all of those IPs are banned. It has to be something else.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.