After add alias Sender address rejected


#1

hello I have successfully created a relay (info@example.com) that works great as synonymous.
I use a main email (webmaster@example.net) to get in all the alerts, infos etc. Now I have an alias for info@example.com to forward the mails to webmaster@example.net.
Unfortunately that did not work out. the following error message comes from the mail system:

info@example.com: Sender address rejected: not owned by user

is the problem with postfix?

here the main.cf from the relay.

# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
#biff = no

# appending .domain is the MUA's job.
#append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

#readme_directory = no

# See http://www.postfix.org/COMPATIBILITY_README.html -- default to 2 on
# fresh installs.
compatibility_level = 2

# TLS parameters
smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
smtpd_use_tls=yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

smtpd_relay_restrictions = permit_mynetworks permit_sasl_authenticated defer_unauth_destination
myhostname = pve.example.com
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
relayhost = [box.example.net]:587
mynetworks = 127.0.0.0/8 185.254.97.0/24 [::1]/128 [fe80::]/64
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = loopback-only
inet_protocols = ipv4

mydestination =
smtp_tls_security_level = verify
smtp_tls_CAfile = /etc/ssl/certs/ca-certificates.crt
smtp_sasl_auth_enable = yes
smtp_sasl_password_maps = hash:/etc/postfix/relay_password
smtp_sasl_tls_security_options =
sender_canonical_maps = hash:/etc/postfix/sender-canonical

#2

The alias HAS to point to the senders ORIGINAL email in order to allow this.


#3

Thanks for your Answer.

i go to MIAB-Control Panel > Mail > Aliases

and entry this

Alias: info@example.com
Forwards To: webmaster@example.net
and check Any mail user listed in the Forwards To box can send mail claiming to be from the alias address.

as far as right?


#4

webmaster should now be able to send mail as info.


#5

I would like the webmaster to receive emails from info.

but it does not work, because the upper error message comes.

Do you have any idea where is the problem?


#6

does not anyone have an idea?


#7

webmaster (wait wrong one … was thinking of hostmaster) IS an alias … so it cannot be used.


#8

webmaster is the admin of MIAB. My goal is it all new email users that I put in MIAB should be routed the emails of it on webmaster, so that I have to use an email (webmaster) at the end instead of adding a new email account to my email program. I hope you can understand what I mean.


#9

@sakis2018 Translation - please correct me if I am wrong…

You want ALL emails to be delivered to the ‘webmaster’ mailbox, so that you can reply to them from ONE account on a email client such as Thunderbird on your PC (phone, tablet, whatever) - correct?
However, when you reply to those emails you want the reply to appear to be sent from recipientemailaddy@domain.com, not webmaster@domain.com - correct?


#10

Yes, that’s exactly what I want.


#11

OK … so what did you mean by …

Did you mean that you had created the ALIAS (rather than relay)?

and is this post in any way related to your post about setting up a mail relay on another server?


#12

Ok here what I’ve done so far.

After creating a new user in the MIAB, I created a relay on the other server (running a forum) using this tutorial https://mailinabox.email/advanced-configuration.html. so far everything has worked. Now I want to redirect all emails to webmasters, as they already described above.

and is this post in any way related to your post about setting up a mail relay on another server?

Yes it is, but I have already solved this problem.


#13

So the relay on the other server which is running a forum is set up for which purpose exactly?

I will assume that it is relaying OUTGOING email from the forum software to the MiaB for delivery to the internet, is that correct?

Please bear with me, I am trying to paint as complete of a picture as possible. :slight_smile:


#14

Yes that’s right so far.


#15

Was this line in your original MiaB configuration, or did you add it … or is this on the install of Postfilx on the ‘forum server’?


#16

This is in the Postfix main.cf on the forum server.


#17

Ok, so to confirm you have made NO changes to the Postfix config files on the miab server?

I am not convinced that the change you made on the forum server was necessary/wanted … but let’s leave that alone for the moment. I need to do some reading, be back shortly.


#18

That’s correct, I have not changed anything to the postfix of MIAB.

Thank you for your effort.


#19

@sakis2018 Which email address or addresses are emails from the forum being sent as?

In other words, what is the from: address?

Are the all being sent as webmaster@domain.com or are there other addresses being used?


#20

Another question … which client are you using to send the emails that you are getting this error? Is it the forum software, or Roundcube? or something else?