Admin won't work

System works fine, but when I got to admin, all I see is a non-styled menu. And worse, when i click the menu, none of the links will work…

Any ideas?

Hello! Welcome to MIAB!

The screenshot suggests your browser is blocking non-ssl (or blocking ssl connection that was not explicitly allowed) or you might be using a self-signed certificate.

While in browser, press CTRL+SHIFT+I (if firefox or chrome) and refresh the page with CTRL+F5. Then copy and paste an errors here so I can help you in troubleshooting :slight_smile:

No… didn’t work.

It seems that it can’t load bootstrap and jquery.

Otherwise, SSL seems ok, certificate valid.

Munim works, because it is a direct link. This happened several months ago after an update and I might be fiddling with the files, I don’t remember…

Hey sorry - holidays are busy for me.

I would re-run the setup then, looks like it is missing a lot of files.

I did. This is what it looks like…

I would recommend rebuilding from scratch, including the OS.

Reinstall ubuntu 14.04, then MIAB.

Well, I can’t. Because I also use the DNS. And I don’t want to change the ip address.

I will dive in to see what i can do… Thanks for your help…

What I don’t understand is, during setup, an assets directory should be created. But it doesn’t. Am I looking at the wrong place?


that is correct (I think?) I didn’t make the install script, I am just a linux fanatic.

That sounds right.

I’m also having that issue and I don’t have much idea what to do, I followed when I couldn’t update properly and it worked perfectly except now when I access /admin/ I get the same results as OP.

I solved the issue by modifying mailinabox/management/templates/index.html

Instead of local files, I included cdn files for bootstrap and jquery.

    <!-- <link rel="stylesheet" href="/admin/assets/bootstrap/css/bootstrap.min.css"> -->
    <link rel="stylesheet" href="" integrity="sha384-BVYiiSIFeK1dGmJRAkycuHAHRg32OmUcww7on3RYdg4Va+PmSTsz/K68vbdEjh4u" crossorigin="anonymous">

    <!-- <link rel="stylesheet" href="/admin/assets/bootstrap/css/bootstrap-theme.min.css"> -->
    <link rel="stylesheet" href="" integrity="sha384-rHyoN1iRsVXV4nD0JutlnGaslCJuC7uwjduW9SVrLvRYooPp2bWYgmgJQIXwl/Sp" crossorigin="anonymous">

    <!-- <script src="/admin/assets/jquery.min.js"></script>
    <script src="/admin/assets/bootstrap/js/bootstrap.min.js"></script> -->
    <script src=""></script>
    <script src="" integrity="sha384-Tc5IQib027qvyjSMfHjOMaLkfuWVxZxUPnCJA7l2mCWNIpG9mGCD8wGNIcPD7Txa" crossorigin="anonymous"></script>

That only works around the issue, you should attempt to locate the files or find out why they never downloaded for you.

Well, that was my intention at first… But, I installed mailinabox on a new fresh DO droplet Ubuntu 14… Same thing happenned… So I thought, it wasn’t me… and made the hack to make it work. Though, certificates don’t work too, I’ll see what I can do about it…