Adding internal dns entries

Hi All,
I have been adding A records for internal servers on my network under custom dns.
Each time I add a local entry I receive an error and the entry is not added.
If I open custom dns again the entry has been added.
Example for a local server entry A

I gather its adding the dns entries properly?

I have found the same error when removing entries. Also the dns entries don’t resolve internally. The error is below

500 Internal Server Error

Internal Server Error

The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there is an error in the application.

MIAB does not support adding local IP’s via the admin panel.

@murgero Why do you say that?

I don’t think there is any problem setting a custom DNS record to any IP address value. There might be another problem — @julians1976, you should check the logs in /var/log/syslog.

@JoshData So If I set the DNS on my computer to my MIAB server, the server will answer my DNS requests? Cause the last time I tried that it failed. Of course adding any IP works, I should have specified that using the MIAB server as LAN DNS doesn’t, unless that was changed recently.

You can’t use a Mail-in-a-Box as a recursive nameserver (i.e. setting it as the DNS server for a workstation) — it won’t resolve any domains except the ones it serves. But you can add whatever custom DNS records you like under the domains you’re serving. Either way, an error while setting a DNS record is a bug.

1 Like