ActiveSync broken for 1 user after upgrade

So I did the upgrade from .44 to .45. Seemed to go well. But there is something broken with z-push/ActiveSync since the upgrade.

For me, my client (Outlook mobile) stopped updating. Deleting the account and re-adding would work fine, but only syn email prior to the upgrade. I eventually gave up on Outlook and tried another client.

Installed BlueMail, using ActiveSync, all mail showed up. I figured problem solved. Turns out BlueMail is no longer syncing anything newer than the original sync. A colleague is also using BlueMail, and he says things are fine.

So it looks like my account is somehow screwed up on the server wit respect to ActiveSync. I read some on the z-push site and there is talk of debugging etc, but as the MiaB has a custom z-push I couldn’t find any of the config files in MiaB.

How can I enable z-push debugging in MiaB? Or how can I reset the z-push service for a particular user?

I did find /var/lib/z-push; it had a couple of files but not much in there. a users file and a settings file. Can I delete the users file?

found the config.php for z-push:

enabled logging, see what happens…


I ended up having to use the z-push admin tool to resync the account.


Seems ok now…