AAAA / IPv6 breaks DNS

Hi Joshua,

First thing first, thank you for your work, I appreciate it.
The best Open Source project I have used so far.

Now to the issue.
I have MIAM latest version (v0.20) on Ubuntu 14.

Everything works perfectly, I have 5 different domains, around 30 subdomains, many users, etc.
Recently I decided to add AAAA record for IPv6. I did it through the web interface. The system said “DNS updated”.

After that I could not add any other record (tried A and TXT).
The system says “DNS updated”, record appears in “Custom DNS” and “External DNS”, I can see zone file and signed zone file, but… “dig hostname @nameserver RECTYPE” returns SOA record. Obviously, name server does not return new record.

I almost decided to reinstall MIAM, but fortunately tried removing AAAA record and everything worked again!

Fail2ban doesn’t currently work with IPv6, you may want to put the brakes on IPv6 until support is released?

Is there a reason you need IPv6 right now or are you wanting to use it just because you can?

You could just manage your records externally?

There is no strong need for me to use it right now.

My point is not (only) that the IPv6 is not working, but rather that MIAM interface lets user save such record and the system stops working properly.

I would suggest either removing the ability to save AAAA records, or at least provide a clear warning like “If you click next, not only AAAA will not work, but also you won’t be able to add more records.”

I have literally just setup an IPv6 address to point to a subdomain, once I did this I created another A record and a TXT record. The box still appears to be functioning and I’m able to ping the subdomains I created along with a visible TXT record.

Have you tried using an IPv6 address again recently? It could have been an accidental misconfiguration.

No I have not.

I will probably try after the next update (MIAM will reconfigure itself).
I have not changed any configuration…

I will post here with the update.

Thank you!

1 Like

FYI, fail2ban 0.10 now has full support for IPv6: