404 not found on /admin/munin/


#1

I’m upgrading from 0.10 to 0.11 and when I try to visit the new Munin page at https://sitename/admin/munin/ I am prompted for credentials, then after entering my login for the /admin/ panel I get a “404 Not Found” page.

The only error I can find is in my nginx error.log:

2015/06/30 02:05:20 [error] 11044#0: *96 open() “/home/user-data/www/default/admin” failed (2: No such file or directory) [removed rest]

I also noticed that in my nginx local.conf this seems to be the only reference to munin:

rewrite ^/admin/munin$ /admin/munin/ redirect;

Edit 1:
I’m also getting spammed every 5 minutes from munin now:

Subject: Cron munin@hostname if [ -x /usr/bin/munin-cron ]; then /usr/bin/munin-cron; fi
Date: 2015-06-30 14:45
From: root@sitename (Cron Daemon)
To: root@sitename

not a reference at /usr/share/perl5/Munin/Master/Utils.pm line 863.


#2

Please be aware that Munin is only accessible under https://box.example.com/admin/munin/ .


#3

My setup is called mail.example.com - is Munin hardwired to use box.example.com?


#4

No.

Give munin a day or two to generate its first set of data. Let us know what happens.


#5

Is this a normal status for Munin:

root@mail:~# service munin status
munin stop/waiting
root@mail:~# service munin-node status
munin-node start/running, process 15861


#6

No change in status, still 404’ing and getting spammed every 5 minutes by the cron job.


#7

I also get the 404 error when attempting to access munin. The service status is the same as DrMartin’s.
I used the standard “box.example.com”-setup.


#8

I have completely reinstalled Mailinabox now (wiped server, reinstalled Ubuntu 14.04, ran the setup script).

Still get the same errors. It is now running 0.12.

I’ve removed the alias for root@mail.domain so I don’t get the spam mails anywhere, but I suspect if other people tried to setup the same alias I did they would also start to get the spams from cron.

Is there an easy way to get this working in a lab environment with port 25 blocked? I tried to do some deeper testing this morning but got stopped by the script when it identified port 25 blocking.


#9

I noticed this guide here which says the Munin files should generate in “5 minutes” if they don’t generate immediately:

https://www.digitalocean.com/community/tutorials/how-to-install-munin-on-an-ubuntu-vps

And also this guy has the same problem but fixed it by overwriting his Munin directory… (??)

https://serverfault.com/questions/620846/munin-not-creating-html-files-in-ubuntu-server-14-04


#10

Silly question, but maybe a full system reboot helps?


#11

Tried it. Multiple times. Doesn’t help.


#12

I bet there are many people with this problem but who just haven’t tried going to Munin to see the error.

I would really like to get this setup in a lab where I could do more testing but the script explicitly blocks setup in networks without internet access (or port 25 access).

And as with Jan, turning it “off and on again” doesn’t fix the problem.


#13

For testing, you should just force it to skip that check. (That’s what I do.) You should be able to do

sudo SKIP_NETWORK_CHECKS=1 setup/start.sh

If you’re using Vagrant (this is how I test), uncomment this line (remove the hashmark).

Or comment-out these three lines (add hash-marks before each line). Or modify this file.


#14

Yeah, I receive the same 404 error. Not sure if there’s a special username/password needed (besides primary account during setup) but I’ve rebooted a few times and updated recently. Still can’t access munin.


#15

404 means auth is working but munin has not generated any graphs.


#16

I can’t figure out what’s going wrong, but I agree with you, Munin is not generating any files - the setup of NGINX and Apache are sound.

I’ve never used Munin before and I don’t really have time to further troubleshoot, but I’ve done 4 unique installations and in none of them does Munin work.

It could be because I’m not using DigitalOcean.


#17

I also have this exact problem as well as I’m noticing in syslog

Jul 15 06:35:02 domain postfix/lmtp[2054]: 64A191F1BD: to=<munin@mydomain.com>, relay=127.0.0.1[127.0.0.1]:10025, delay=0.11, delays=0.06/0/0/0.05, dsn=5.1.1, status=bounced (host 127.0.0.1[127.0.0.1] said: 550 5.1.1 <munin@mydomain.com> User doesn't exist: munin@mydomain.com (in reply to RCPT TO command))

Looks like whatever it tried to set up didnt work/finish


#18

Well I walked through the Ubuntu guide for Munin and eventually it started working. I’m not sure what change I made that did it but creating aliases for munin, editing the munin.conf and munin-node.conf, as well as creating directories which didn’t exist seems to have done the trick. I’m not using digitalocean so that may have something to do with it as some of the directories are different (?) but anyway it’s working now…


#19

Which guide did you use? Do you have a link to it?


#20

I cannot quite say I followed this to the letter because I did alot of jumping through logs and tweaking stuff til it started working… Again I’m not 100% what I did to get it going but this guide will point you at least on where to look… pretty boiler plate stuff…

EDIT: Oh and I guess it goes without saying to ignore the apache stuff…