404 not found on /admin/munin/


#21

Hahaha this is so stupidly simple. :smile:

I even used this guide before but I guess I missed that the directory hadn’t been created.

I fixed it in less than a minute by doing this:

sudo mkdir /var/www/munin
sudo chown munin:munin /var/www/munin

and then

sudo service munin-node restart

Works now.


#22

Glad we could get to it… I also created this directory and opened it up (didn’t exist) so that was probably it. … Good job man :thumbsup:


#23

We are configuring munin to use a differently directory so this fix would not apply to Mail-in-a-Box.


#24

I am using a clean install, then the mailinabox script… so it seems like some servers just won’t work without that directory.


#25

I checked again… the directory i created was a actually
/home/user-data/www/default/munin
and
/home/user-data/www/default/admin

It’s possible neither of these directories are correct either… anyway something we both did got it working.
Clean installs


#26

I had the same error when migrating. I could fix it by setting the hostname of the munin-node correctly.

Check what’s the hostname used by the munin-node:

nc 127.0.0.1 4949

This should return something like box.mydomain.com. My returned box.mydomain.com.local, which is wrong. So set it manually:

nano /etc/munin/munin-node.conf

Find

#host_name

And set it to host_name box.mydomain.com


#27

Okay I think this is fixed, see: