0.51 update & DNS issue

Upgraded 2 MIAB servers. One running Ubuntu 18.04.5 now has an IP6 issue in the status screen saying

:heavy_multiplication_x: Public DNS (nsd4) is running and available over IPv4 but is not accessible over IPv6 at xxxx.xxx etc. port 53.

I checked the status page, re-ran setup, and rebooted the box. Error remains.

Suggestions please?

This problem has not resolved itself. My server is utilizing AWS SES and is now inoperable due to failed DNS communication.

Should I build a new server with version 0.51 and see if the problem goes away?

For anyone still monitoring the thread and wondering whether to upgrade; I just upgraded with zero issues (I’m running a vanilla MIAB unmodified Nextcloud instance though).

1 Like

I never did figure out what happened, so I built a new server with 0.51. The ipv6 issue is gone. Now however I’m having trouble migrating my mail from the old to the new box per instructions given at https://mailinabox.email/maintenance.html#moving-boxes

Hi @christian7

If you want to post where you are stuck in the process I’d be happy to try to help you out here. Or maybe offer another option. Is the original server still running, or are you working with just the encrypted backup?

Thank you for your support. The older server is still running. I did a final backup, then SCPed the encrypted folder and the secret_key.txt file over. I then ran these commands

$ export PASSPHRASE=$(cat secret_key.txt)
$
$ sudo -E duplicity restore --force file:/home/aztlan/encrypted /home/user-data/
[sudo] password for aztlan:
gpg: WARNING: unsafe ownership on homedir ‘/home/aztlan/.gnupg’
Synchronizing remote metadata to local cache…
GnuPG passphrase for decryption:

I don’t recall setting a GnuPG passphrase. Please advise. Thank you!

still waiting for assistance on this. am stuck.

Did you try to enter the content of the secret_key.txt for the password?

yes. that did not work.

Hi Christian,

This seems to be done automatically by the backup script. The “passphrase” is the key in the text file. (you may search in this area: Why does it seem it isn’t taken into consideration?)

Ideas: Did you indeed copy the files and key into “/home/aztlan/encrypted” on your new box? Are you in that directory when running the commands? (or at least the directory where the key.txt is located when running the first command)

On the guide, there is 3 “///” after “file:”. Is that a mistake in the guide? Did you maybe try it?

Apart from this, I’m unable to think about anything else to try to help you.

Another thing to try: Just using the first line of the secret_key.txt.

Is there a solution for the original issue here? I also have it after upgrading to the latest MIAB.

That user resolved their issue by migrating to a new VPS. In your case you upgraded to v 0.52 and are just now having this issue? Who is your VPS provider?

Yes, I upgraded to 0.52 yesterday and the issue started happening yesterday after the upgrade. I believe I was on 0.50 before the upgrade. My VPS provider is Linode. I would prefer not to have to migrate to a new VPS since setting up IPv6 and reverse DNS was nontrivial.