Wrong time(zone?) when viewing calendar entries on Android

I’ve run MIAB for 2+ years now, and have always just dealt with this issue, but I can’t take it anymore. I’m not sure if this is NextCloud or Z-Sync related, or maybe even Android related, but when I create a calendar entry from NextCloud and set the time, I get a different time when my Android phone syncs that entry.

I’m in EST, and it’s my understanding that NextCloud uses jstz to auto-detect TimeZone, and I think that that is working correctly (as when I change the timezone in a calendar entry, it says New York, which is the same I get when I visit https://pellepim.bitbucket.io/jstz/).

So let’s say I create a calendar entry for 10:00 AM in NextCloud, once it syncs with my phone it says 5AM. Seeing as EST is -5 UTC, this makes me think my phone is showing time as UTC and not EST as NextCloud is doing. Is there a setting for this? I’m thinking PHP or Nginx setting might apply here, but I’m not sure. If I run date on my MIAB instance, time is reported back in UTC. Looking at /etc/php5/fpm/php.ini, I can see that date.timezone is commented out, so nothing set there.

Surely I’m not the only one that has this issue! Please help.

Did you setup your desired time zone at your server, too? That can be accomplished by reconfiguring the tzdata package by running:

sudo dpkg-reconfigure tzdata

Hope this helps.

Like I said, I was sitting on UTC at the system-level. Wasn’t sure if that was the setting that would fix my issue, but I went ahead and ran sudo dpkg-reconfigure tzdata and rebooted (for fun), and will report back if that fixes my issue.


1 Like

Setting the server timezone seems to have fixed my issue.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.