Why there have apache after installing finish (very clear ubuntu)

I used 3 kind of ubuntu
1st is clear system in conoha
2nd i remove apache first in digitalocean.
3rd is in host1plus
but

finaly there will have apache, who know that why?

when i open server ip, will have apache page
if open https://ip/admin cannt open

I already try 3 times, same result

:sob:

Uninstall apache: apt-get remove apache2

yes,i already removed apache, but after installed, there still have apache

ok, solved now

  1. install cp first
    2.remove apache
    3.install cp again

very intresting, even i remove apache first, after installing process “apache remove”, then apache come back
only me have this problem?

Hello baiyun888,

That is not what is happening. I started a thread there a month ago on something similar to what you are getting.

What is happening is it seems ubuntu is installing Apache late. When I went to install MiaB on a VM I checked for Apache before starting the install and it was not there. Then the install errored out and I found Apache. So I assumed the same thing you did. But I tested it. I did a fresh install of Ubuntu on another VM, and looked for Apache and did not find it. Let it sit for a bit and then came back. Apache was installed.

So for people having this trouble, it seems the Apache install runs in the background when you first setup Ubuntu.I did not get this issue on my VPS, only on self installed Ubuntu, so it might depend on the version and the host’s image.

Chess

When installing Ubuntu do NOT select “LAMP Server” During installation.

Hello murgero,

Good advise. However the only thing I select when installing Ubuntu for MiaB is SSH Server. But the next time I install I’ll see if that one is selected by default.

Chess

It might be, I do not remember off the top of my head.

hi cwilkins
yes, im very sure there have no apache inside Ubuntu, very clear
but after CP installing, apache is there, host1plus/conoha/digitalocean they are same
so have you solved your problem?

Sorry, I had intended to update this thread when I did another install of MiaB with the answer to the above. I’m moving my MiaB to another dedicated host (always trying to save money) and no LAMP is not installed be default.

However, Apache2 was installed again even when it was not selected. It did not show up until I had run the MiaB setup. I had to remove it and re-run the MiaB setup a second time to get the box setup correctly. I’m starting to wonder if the current ISO for Ubuntu is installing Apache2 for some reason, even if it is not selected. This was not the case on on droplet, just when I install using the ISO.

1 Like

I suspect you already have your answer, I just uninstalled Apache and then reran the MiaB setup to correct my issue.

1 Like