Webmail roundcube does not work on new install [Fixed by hosts file]


#1

Hi,

new install of 0.40 on clean Ubuntu 18 . admin seems to be working fine , however Webmail , or IMAP is not . if i try with roundcubemail :

IMAP Error in /usr/local/lib/roundcubemail/program/lib/Roundcube/rcube_imap.php (196): Login failed for my@email.here from xx.xx.xx.xx. LOGIN: Login failed.

i also see in roundcube/imap when debug enabled :

[18-Feb-2019 17:58:07 +0200]: [8913] S: * OK [CAPABILITY IMAP4rev1] Courier-IMAP ready. Copyright 1998-2005 Double Precision, Inc. See COPYING for distribution information.
[18-Feb-2019 17:58:07 +0200]: [8913] C: A0001 LOGIN ****** [48]
[18-Feb-2019 17:58:12 +0200]: [8913] S: A0001 NO Login failed.

reboot doesnt help. Any help please ?


#2

Is there any slight possibility that the authentication details were entered incorrectly? Cap locks key on, or something similar?

Perhaps add a second user and see if the issue persists.


#3

Also non-US characters in usernames and passwords can be a problem.


#4

nope, just created a test user with test1234 password - same result .
weird, only log form roundcube is being produced , mail.log says nothing - last info - dovecot restart.

How can i check if IMAP works at all ?


#5

Found this line as well , not sure if it can be the reason
doveconf: Warning: SSLv2 not supported by OpenSSL. Please consider removing it from ssl_protocols.


#6

Attempt logging in with a different client such as Thunderbird.
Alternatively see if the server is responding by trying to telnet to it:
telnet box.domain.al 993


#7

Aha, fixed it !

I think developers should check if localhost is defined in hosts file . In my case as WEB is hosted separate i had :

using external DNSes :

xx.xx.xx.xx mydomain.com
xx.xx.xx.xx *.mydomain.com
thus whith wildcard domain settings

then i installed mailinabox to yy.yy.yy.yy IP:
yy.yy.yy.yy mailinabox.mydomain.com

and somehow my hosts file had missing
127.0.0.1 localhost
entry

thus using wildcard DNSes localhost where resolved to localhost.mydomain.com -> xx.xx.xx.xx , outside of the mailinabox. and thats where roundcube where trying to connect :slight_smile:

Thank for help !


closed #8

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.