Web error creating new DNS entry and error also showing "External DNS"

When I create new DNS entry I recieve a message:

"Custom DNS (Error)

title>500 Internal Server Error
h1>Internal Server Error
p>The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there is an error in the application.


(I delete the start tags “>” becouse not showed well)

When I update the page, the entry is here and it stores correct on /home/user-data/dns/custom.yaml but not update the file on /etc/nsd/zones/

The DNS respond correctly old registers but not the newers.

I tried uninstall nsd and lauch the Mail-in-a-Box setup again, restart the server, empty custom.yaml to start from zero and empty /etc/nsd/zones/. The problem seems the processs that write on /etc/nsd/zones/.

I tried also lauching dns_update.py, but I don’t know if I can lauch from terminal but I recieved errors from it.

The section “External DNS” show an error and not show any record.

It happens some months ago and I can’t say when starts, on last MIAB update or system update, or entry added. I have VPS with Ubuntu 14.04.5 with 1GB RAM, and is working well more than one year ago. I use the API to modify one register that I use as Dynamic DNS for home IP.

Any tip or help please?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.