V0.42b Public DNS (nsd4) is not running (port 53)

hi guys,
after upgrading to v.0.42b (step-by-step as recently mentioned here:

i get
Public DNS (nsd4) is not running (port 53).
in the “System Status Checks”

Commandline looks like this:

root@box:~# service nsd status
● nsd.service - Name Server Daemon
   Loaded: loaded (/lib/systemd/system/nsd.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Sun 2019-08-11 09:22:53 CEST; 3h 25min ago
 Main PID: 595 (code=exited, status=1/FAILURE)

Aug 11 09:22:53 box.XXXXXX.at systemd[1]: nsd.service: Service hold-off time over, scheduling restart.
Aug 11 09:22:53 box.XXXXXX.at systemd[1]: nsd.service: Scheduled restart job, restart counter is at 5.
Aug 11 09:22:53 box.XXXXXX.at systemd[1]: Stopped Name Server Daemon.
Aug 11 09:22:53 box.XXXXXX.at systemd[1]: nsd.service: Start request repeated too quickly.
Aug 11 09:22:53 box.XXXXXX.at systemd[1]: nsd.service: Failed with result 'exit-code'.
Aug 11 09:22:53 box.XXXXXX.at systemd[1]: Failed to start Name Server Daemon.

What’s wrong here? What to do? Thank you for your help…

Is IPv6 enabled in your OS? @stephank

Look here for info:

THANKS A LOT!

sysctl -w net.ipv6.conf.all.disable_ipv6=0
and
sysctl -w net.ipv6.conf.default.disable_ipv6=0
then
service nsd start

did the trick.

All system services are running.
hooray!

1 Like

Thanks for sharing the solution … you’re not the first one this week to encounter this.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.