Upgrade fails as nextcloud-16.0.6.zip is not available

I’ve tried to upgrade to the latest version of MIAB with the curl command detailed in the maintenance page:

curl -s https://mailinabox.email/setup.sh | sudo bash

Here is the result:

    Primary Hostname: box.mydomain.com
    Public IP Address: 12.34.567.89
    Public IPv6 Address: 1234:1234:1234:1234
    Mail-in-a-Box Version:  v0.44

    Updating system packages...
    Installing system packages...
    Initializing system random number generator...
    Firewall is active and enabled on system startup
    Installing nsd (DNS server)...
    Installing Postfix (SMTP server)...
    Installing Dovecot (IMAP server)...
    Installing OpenDKIM/OpenDMARC...
    Installing SpamAssassin...
    Installing Nginx (web server)...
    Installing Roundcube (webmail)...
    Installing Nextcloud (contacts/calendar)...
    Upgrading Nextcloud --- backing up existing installation, configuration, and database to directory to /home/user-data/owncloud-backup/2020-04-25-13:33:43...

    Upgrading to Nextcloud version 16.0.6

    FAILED: wget -O /tmp/nextcloud.zip https://download.nextcloud.com/server/releases/nextcloud-16.0.6.zip
    --2020-04-25 13:33:44--  https://download.nextcloud.com/server/releases/nextcloud-16.0.6.zip
    Resolving download.nextcloud.com (download.nextcloud.com)... 2a01:4f9:2a:3119::181,
    Connecting to download.nextcloud.com (download.nextcloud.com)|2a01:4f9:2a:3119::181|:443... failed: No route to host.
    Connecting to download.nextcloud.com (download.nextcloud.com)||:443... failed: Connection timed out.

    --2020-04-25 13:35:56--  (try: 2)  https://download.nextcloud.com/server/releases/nextcloud-16.0.6.zip
    Connecting to download.nextcloud.com (download.nextcloud.com)|2a01:4f9:2a:3119::181|:443... failed: No route to host.
    Connecting to download.nextcloud.com (download.nextcloud.com)||:443... failed: No route to host.

After that, I could access the admin, but when I tried to connect to the inboxes, cloud contacts or calendar, I got a 502 nginx Bad Gateway error. I rebooted the server and it allowed me to connect to my inbox.

So where do we go from there? I guess the .zip file would require to be reuploaded or hosted elsewhere in order to have the upgrade complete.

It would seem that NextCloud’s servers are down at the moment.

I just anwered a very similar question on Slack.

My recommendation would be to wait an hour or two and then try again. @Pedro

1 Like

Yes, it’s now back online.

Maybe this isn’t actually the case, but it seems like NextCloud being down accounts for a decent number of installation and upgrade failures. It’s got me at least twice and I think that has actually been my only installation issue.

Would it be feasible to mirror the archive? Or download it first or at least test that it’s available prior to running the rest of the installation script?

This is an interesting suggestion … may I suggest that you bring this idea to the project’s GitHub page where the developers are? :slight_smile: