Unable to upgrade

hi, i tried to upgrade mail-in-a-box but getting error:

# curl -s https://mailinabox.email/setup.sh | sudo bash
Updating Mail-in-a-Box to v57a . . .
remote: Enumerating objects: 1, done.
remote: Counting objects: 100% (1/1), done.
remote: Total 1 (delta 0), reused 1 (delta 0), pack-reused 0
Unpacking objects: 100% (1/1), done.
error: Your local changes to the following files would be overwritten by checkout:
Please commit your changes or stash them before you switch branches.
Update failed. Did you modify something in /root/mailinabox?

i did not made a changes and tried to install it again with “mailinabox” command, but without success… is there some logs?


What version of MiaB is currently installed?

v56, and he offer me for upgrade to v57a

Well, it seems like someone changed a file.

Can you verify the contents of mailinabox/conf/fail2ban/jail.conf matches the contents in the GitHub repo for your current version:

And can you post the output of:

ll mailinabox/conf/fail2ban/jails.conf


ll mailinabox/conf/zpush/backend_imap.php

And verify the dates are the same?

yes it is same as on github (that is first what i checked).

-rw-r–r-- 1 root root 2141 Aug 12 11:47 mailinabox/conf/fail2ban/jails.conf
-rw-r–r-- 1 root root 2357 Apr 9 00:25 mailinabox/conf/zpush/backend_imap.php

they are not?

It looks like there was some kind of change made to jails.conf, because both of those files were changed on version 54 and then not changed until version 57. I’m not any kind of git expert or anything, but maybe even if the file was opened, nothing changed in the text, but the date changed, maybe it interprets there is some kind of change from what the file was when you very first put it on server.

You might try posting over on the Slack channel on how best to handle this. I don’t think it’s anything that difficult.

1 Like

to try to remove folder and do install again? :smiley:

Something similar would be to move the current folder to a backup location such as mv /root/mailinabox /root/mailinabox-problem-backup then run the install command.

I can’t think of a reason this would be a problem, but I’ve never tried it. It’s why I suggested posting in Slack, as that usually attracts different sets of eyes than the forums.

yeah, all is fine, tnx.

1 Like