Unable to send mail after v0.40 upgrade: NOQUEUE Recipient address rejected


#1

Hi. I run MIAB on Linode, and today migrated my 0.30 instance to 0.40 on a new Linode 1GB instance. The upgrade process and backup/restore process all worked without errors, and my new instance is receiving mail correctly. However, I am unable to send mail to any domain other than my own. The error I see on the mail client (Roundcube or Thunderbird) when sending is:

SMTP Error (550): Failed to add recipient “recipient-email-redacted” (5.1.1 <recipient-email-redacted>: Recipient address rejected: recipient-domain-redacted).

On the server’s mail.log, I see:

Jan 19 21:54:06 my-hostname-redacted postfix/submission/smtpd[8376]: NOQUEUE: reject: RCPT from localhost[127.0.0.1]: 550 5.1.1 : Recipient address rejected: recipient-domain-redacted; from= to= proto=ESMTP helo=

I’ve re-run the mailinabox command a few times for good measure, rebooted the server, triple-checked my DNS settings (which are hosted on an outside DNS service), etc. I’m not sure what’s wrong here. My forum searches for this error haven’t come up with much. Can anyone suggest some further things for me to try out? Thanks -ScottG


#2

Unfortunately I’ve had to revert to my previous VPS with MIAB v0.30 for the time being so I can send mail again. I’ll keep the v0.40 box around for another week or so in case it’s helpful for me to look up anything about the configuration.

The few references I’ve seen to NOQUEUE errors have had to do with greylisting. Given my mail.log entry and how quickly the error occurs, I’m pretty sure this is my own box rejecting my ability to send mail, and not the recipient’s box rejecting the email. That might be a useful clue.


#3

This is just a hunch, but be sure that all the aliases are correct if you have any. I had one with just an entry in the ‘Permitted Senders’ column and it was doing something wacky similar to this.


#4

NOQUEUE means that the postfix server hasn’t queued an incoming mail for further processing.

The rest of the line tells you the reason.
If it was down to Greylisting, you’d actually see a

450 4.2.0 <my@emailaddress.com>: Recipient address rejected: Greylisted, see http://postgrey.schweikert.ch/help/timothydutton.co.uk.html

In the log


#5

Delete and re add the user account that you are using to send mail.


#6

Just thought I’d follow-up here and note that I finally had time to create another Linode and make another attempt at this, and everything worked fine this time. I’m not sure what caused the problem the first time, but thanks nonetheless to the folks who took time to offer advice in this thread.


closed #7

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.