Unable to provision Letsencrypt certs

I’ve been struggling to provision letsencrypt certificates for my domain “sqzi.com” for a few days now and would really appreciate any insights you guys are able to offer.
When I click the “Provision” button, after a delay I get the error “Something has gone wrong, sorry” and then the button is disabled, even after a reboot.
I tried to have a look at the /var/log/letsencrypt/letencrypt.log but it is very long and I didn’t really know what I was looking for to be honest.
I have already set my email and accepted the TOS and interestingly, I am also able to successfully request a certificate manually using:
certbot certonly --config-dir /home/user-data/ssl/letsencrypt -d sqzi.com

I’m not sure how to get it installed correctly from there though.

Many thanks in advance.

Could you provide part of the letsencrypt log? Hard to tell from here what’s happening

Also, perhaps the output of sudo systemctl status mailinabox is helpful.

Hi Jan,
The log’s 1000s of lines long but here’s the last bit containing tracebacks which I doubt are a good sign. If there’s anything in particular you’d like me to post from the log please just let me know. I tried to post more but the forum won’t let me due to all the URLs. Thanks.

2024-02-07 03:35:20,240:DEBUG:certbot._internal.error_handler:Calling registered functions
2024-02-07 03:35:20,240:INFO:certbot._internal.auth_handler:Cleaning up challenges
2024-02-07 03:35:20,240:DEBUG:certbot._internal.plugins.webroot:Removing /home/user-data/ssl/lets_encrypt/webroot/.well-known/acme-challenge/fqtuUoBoFuxV
2024-02-07 03:35:20,241:DEBUG:certbot._internal.plugins.webroot:Removing /home/user-data/ssl/lets_encrypt/webroot/.well-known/acme-challenge/ESfLMM9XJJ4c
2024-02-07 03:35:20,241:DEBUG:certbot._internal.plugins.webroot:Removing /home/user-data/ssl/lets_encrypt/webroot/.well-known/acme-challenge/H9jFvr-SWAhI
2024-02-07 03:35:20,242:DEBUG:certbot._internal.plugins.webroot:All challenges cleaned up
2024-02-07 03:35:20,242:DEBUG:certbot._internal.log:Exiting abnormally:
Traceback (most recent call last):
File “/usr/bin/certbot”, line 33, in
sys.exit(load_entry_point(‘certbot==1.21.0’, ‘console_scripts’, ‘certbot’)())
File “/usr/lib/python3/dist-packages/certbot/main.py”, line 15, in main
return internal_main.main(cli_args)
File “/usr/lib/python3/dist-packages/certbot/_internal/main.py”, line 1574, in main
return config.func(config, plugins)
File “/usr/lib/python3/dist-packages/certbot/_internal/main.py”, line 1419, in certonly
cert_path, chain_path, fullchain_path = _csr_get_and_save_cert(config, le_client)
File “/usr/lib/python3/dist-packages/certbot/_internal/main.py”, line 1353, in _csr_get_and_save_cert
cert, chain = le_client.obtain_certificate_from_csr(csr)
File “/usr/lib/python3/dist-packages/certbot/_internal/client.py”, line 300, in obtain_certificate_from_csr
orderr = self._get_order_and_authorizations(csr.data, best_effort=False)
File “/usr/lib/python3/dist-packages/certbot/_internal/client.py”, line 439, in _get_order_and_authorizations
authzr = self.auth_handler.handle_authorizations(orderr, self.config, best_effort)
File “/usr/lib/python3/dist-packages/certbot/_internal/auth_handler.py”, line 90, in handle_authorizations
self._poll_authorizations(authzrs, max_retries, best_effort)
File “/usr/lib/python3/dist-packages/certbot/_internal/auth_handler.py”, line 178, in _poll_authorizations
raise errors.AuthorizationError(‘Some challenges have failed.’)
certbot.errors.AuthorizationError: Some challenges have failed.
2024-02-07 03:35:20,243:ERROR:certbot._internal.log:Some challenges have failed.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.