Ubuntu 16.04, MIAB 0.26c -> 4.0

I am currently running the fork that was created by jirislav(https://github.com/jirislav/mailinabox) which was kept up to date until version .26c. I know about a year ago he started helping on the 18.04 work, but as GH shows he moved on.

I am wondering if anyone has tried this upgrading? Or more importantly, what PHP changes are in version .3 that require us to be at that level. His fork was already on php7 if that was one of the reasons.

If no one knows I might try to somehow recreate his code with a different domain I own and try the upgrade on that.

Any help would be really appreciated

–I would backup, snapshot, and backup again. Then Rebuild your MIAB with ubuntu 18.04 FRESH. Then install MIAB and restore the backup.

Edit: Backup as in Backup of MIAB using the MIAB UI and scripts.
Edit again: Looks like you need to be at 0.30 first then the backups will be compatible.

how come you chose to use ubuntu16.04, 14.04 is still getting security updates and was safe to use until 18.04 came out.

What you can try is:

  • Backup (both using MIAB and some imaging like a snapshot or other backup software like Datto.
  • Attempt to upgrade MIAB by using JoshData’s repo (UNTESTED USE AT OWN RISK:


# Under the user account you used to originally install MIAB:
cd mailinabox
# Set the remote URL to JoshData's Repo, this will be used to prevent you from using 
# the custom repo you have setup
git remote set-url https://github.com/mail-in-a-box/mailinabox
# Reset current local copy of the repo to the Master branch of MIAB from JoshData:
git fetch origin
git reset --hard origin/master
# Clean all local files / modifications
git clean -f
# Fetch the current release tags to be used in the bootstrap script
git fetch --all --tags --prune
# Checkout the tag we need, since on 16.04, lets try v0.30
git checkout tags/v0.30 -b master
# Error? Try git pull before the fetch command.
# Once checked out successfully:
nano setup/bootstrap.sh
# Find the line "elif [ "`lsb_release -d | sed 's/.*:\s*//' | sed 's/14\.04\.[0-9]/14.04/' `" == "Ubuntu 14.04 LTS" ]; then"
# Change the "14"s to "16"s
# Run the script:
bash setup/bootstrap.sh
# Got another error running boostrap? It might not technically be needed here since we are only updating to .30, so try:
bash setup/start.sh


I don’t know, just a stupid decision I made 2 years ago when I saw jirislav’s fork. At the time mabye MIAB looked dead? I regret it now.

I am trying to just do a straight up upgrade, but letsencrypt is down right now:

@slenk Have you used NextCloud functionality at all?

@alento - never really before. I knew they existed but found it annoying to sync the calendar, so I stuck with google for that

@murgero too - I am thinking since I didn’t use the nextcloud features, it all worked perfectly.

The second time I ran MIAB with backup data it said something like “Performing upgrade #11” and “performing upgrade #12”. Everything seems to have worked - my mail is syncing, I am able to send AND receive email from gmail, my records are showing correct in the status page (i need to change my ipv6 records yet), but everything seems to just work

Awesome news then! :slight_smile: I think that people who actively use NextCloud may not have such an easy time of it.

Wait - My untested instructions worked for you? Nice. Kudos to me then haha

Good job bud, glad it worked out then :stuck_out_tongue:

In all honesty, it should be removed in favor of SOGo. Same with Roundcube.

Actually I ended up just upgrading from .26c. I just wanted to try that and see what errors I got, but it appeared to work. Yours was going to be step 2.

I initially posted before actually trying because I was nervous but turns out it was unwarranted. I would be interested in seeing if anyone else comes from 16.04 like I did. It had a decent following/use rate when it was being kept in sync with the official miab.

1 Like

We’ll see. I will be willing to help. Thank you for the quick responses @alento

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.