Tracking domain SSL

Good afternoon, ladies and gentlemen. Please help me solve the problem. MIAB is installed as the DNS server and manages all records. I send via Mailwizz and need to link a domain for tracking. I add track.examle com to the CNAME in miab in this form track.example com value: mainserver.com and add the tracking domain to mailwizz. Mailwizz sees this domain and starts using it when replacing links. Only problem is that when I go to this link track.example.com I see a message in Firefox PR_END_OF_FILE_ERROR. I already tried to add the A entry of the main server to the mailinabox, but got the same result. I tried installing Mailwizz on other servers and using other domain registrars, but the problem occurs when I use MIAB, everything works with other services. I have a suspicion that CNAME is not working correctly and I have no way to get a certificate on the server for track.example com since I don’t know the commands for this and probably don’t understand the logic. Dear, please, if someone uses a combination of Mailwizz and MIAB, tell us how you set up tracking. I don’t know how to do a redirect, I saw an article about custom.yaml (an undocumented function), but I couldn’t redirect it because the changes are simply not applied. I really need your help, I will be extremely grateful. Thank you.

To have a second domain or a subdomain, you create an email user for that domain.

I’d try removing the CNAMEs and stuff that you just added (they might confuse MIAB), then create a user@track.example.com.

1 Like

Thanks for answer, but it doesn’t work. When i create a user with mail@mailwizz.miab.com i have this domain Mailwizz.miab.com but i need the redirect when user ask track.miab.com he need go to mailwizz.com. Its tracking domain. sorry for my English
When i ask track.miab.com i need to redirect where my mailwizz
Track.miab.comMailwizz.com

Please, someone! Explain how to make mailinabox work correctly for tracking, so that it redirects to where I need it. I’ve already done everything. I added CNAME, added IP addresses, whatever I did. Does anyone have instructions on how to properly set up a tracking domain? My hands have already given up (

Okay, here’s what I do. First I tried making a CNAME record while removing everything else. For example track.miab.commailwizz.com This started to work, but in this case I cannot issue a certificate, since mail in a box says that “the site is located somewhere else.” And it seems like he’s trying to translate it to the site. Next, I created a user test@track.maib.com to obtain the certificate and deleted the CNAME record track.maib.commailwizz.com. I received the certificate, but now the CNAME entry does not work, if I add track.miab.com to the CNAME then I get the page this is a mail-in-a-box

ok, i solve the problem. thanks all

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.