TLS Automatic Cert Provisioning

I am on v.48 , and I am getting this error

The TLS (SSL) certificate has a problem: The certificate has expired or is not yet valid. It is valid from 2020-08-17 06:35:52 to 2020-11-15 06:35:52.

Not auto provisions of the cert?

There should be… what happens when you run

sudo ~/mailinabox/management/ ?

Travelling, will try it from DO web terminal.

1 Like

Is there another method to troubleshoot. I have limited internet and only access to mobile phone

Probably not. If you are away and need it fixed, I am available for a very reasonable fee. Assuming, that is, you have the means to convey me the login details.

Alternatively, there are SSH clients for mobile.

Let me know if I can help.

I ran the command abov

sudo ~/mailinabox/management/ ?

Should the question mark (?) be included

No, It should not be included.

How do I page the results? Of the command

I am using external DNS, Namecheap , I have the A record pointing to IP, using the subdomajn, and I upgraded to .51

As the certs are issued for all subdomains, please confirm that you have all of them listed in DNS.

So when you go to the SSL/TLS page now, what is being indicated?

The domain name does not resolve to this machine: [ Not Set] (AAAA)

I am not seeing any entries at NameCheap in their DNS for the subdomains


Are they necessary??? I thought they were for active syncs

I noticed yesterday while helping someone out that the certificate is issued with these subdomains … I think that is a question that needs to be addressed separately of the devs @JoshData.

So since LE is instructed by MiaB to issue certs for the subdomains, yeah they are required.

But honestly, I am still not getting a clear picture of the situation with your installation as the error you mentioned usually shows up in status checks, not on the tls/ssl page … so I am a bit confused.

So create all records foe them or just the A records

Just the A records are needed.

Done. Do I need to run the management command…again.

Take a look at the TLS/SSL page and see if there is a Blue Provision button.

Install certificate. No provision

Is DNS resolution working on your MiaB?



What output do you get from each of these commands?