That’s not a valid email error

Install script:

curl -s []( | sudo -E bash


  1. setup/ line 19: /usr/local/lib/mailinabox/env/bin/pip: No such file or directory
    1. Solution: cp /usr/local/lib/mailinabox/env/local/bin/ /usr/local/lib/mailinabox/env/bin/
  2. ERROR: Cannot uninstall 'blinker'. It is a distutils installed project and thus we cannot accurately determine which files belong to it which would lead to only a partial uninstall.
    1. Solution: pip install --ignore-installed pyOpenSSL
  3. A blue popup with “That’s not a valid email address.”
    1. This is one I need help on.

I included other errors and solutions just incase an action I took caused the error.

This might be due to your solution in step 1. Try with a clean installation, or remove env directory under /usr/local/lib/mailinabox/, then try the solution described in the other thread using

curl -s | sudo -E bash

I found that if I hold the enter key on that invalid email screen, it will flash up and error.
Added the screenshot.
Looks like an issue with the ‘validate_email’ section of the script.

I tried commenting out some parts but it just showed other errors relating to the ‘validate_email’ part.

I tried several work-arounds in order to to bypass the whole thing as I don’t need it to check if it’s valid.

I will try what @KiekerJan wrote to see if that helps. Just thought I’d add my findings with the error messages that I was getting.

It looks like the python email_validator is not installed properly. This might be fixed by:
sudo pip3 install "email_validator>=1.0.0" but to me it points to a deeper error: what else has not been properly installed? Still, it might help to try this command to see if it produces an error.
Basically you should have a clean run of the mailinabox installation script.

Thanks. Tried that command and it’s alread installed and latest version.
I didn’t have this much trouble a few weeks ago. I installed MIAB (with only a few errors, which I was able to fix) and all went smoothly.

Output from your command:
Requirement already satisfied: email_validator>=1.0.0 in /usr/local/lib/python3.10/dist-packages (2.1.0.post1)
Requirement already satisfied: dnspython>=2.0.0 in /usr/local/lib/python3.10/dist-packages (from email_validator>=1.0.0) (2.4.2)
Requirement already satisfied: idna>=2.0.0 in /usr/local/lib/python3.10/dist-packages (from email_validator>=1.0.0) (3.6)

You can try a similar command for the mailinabox python environment:

sudo /usr/local/lib/mailinabox/env/bin/pip3 install "email_validator>=1.0.0"

The email validator is installed in the virtual env, as are other items that are needed during setup and management. My understanding is, when a venv is created, various variables are set according to where things are placed under the root of the virtual env. So, moving things around and copying things from one location to another after it has been created is likely to not solve the problem, but add to it.

Unfortunately, I still cannot reproduce this problem on my server, so I can only theorize on causes and fixes. If someone whose system is experiencing this problem is willing, I’d like them to try creating the virtual env by hand, first without the DEB_PYTHON_INSTALL_LAYOUT variable set. Look in the directory and see if it placed bin under local/, and if so, then remove virtual env, set the DEB_PYTHON_INSTALL_LAYOUT variable to deb as has been discussed and create the venv again. And again, look to see where it has placed the bin directory.
Do this as root, and please report back your findings.

The command to create the venv is:
virtualenv -ppython3 <directory>
You can choose where you want the directory to be. Since it’s just an experiment, you don’t have to put it where mailinabox puts it. For example, you could use /root/tmp/venv for the directory.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.