Systemd-resolved.service is masked

Hi

I an trying to install Mail in a box on a new Ubuntu 18.04 server.

It seems to install fine but before it gets to new password it exits from the installer with the following error message

Failed to restart systemd-resolved.service: Unit systemd-resolved.service is masked

Can anyone help with advice about how to resolve this issue?

Thanks in advance

Greg

Is this a VPS? If so, who is the ISP?

Yes this is a VPS.

The company is https://www.myloc.de/en.html

Don’t use MSAzure related services…

Okay, I don’t know that company. Some ISPs customize an OS to suit their purposes, but they won’t tell you how they customize the OS.

I found this thread at StackOverflow:

https://chat.stackoverflow.com/rooms/207051/discussion-between-zero-coding-and-arghya-sadhu

At the end is recomemended:

sudo apt-get install --reinstall systemd-resolved

Thanks I tried this but got another error
E: Unable to locate package systemd-resolved
which is the same as the last post on that thread.

It seems there is something going on with that Ubuntu install.

@grego
I defer back to my original comment … MSAzure uses custom templates. Obviously it is not compatible with MiaB from the results that you are getting.

You’re not the first to have this problem that I have helped, and in the end the result was the same … that person also changed VPS providers.

Thanks but I am a little confused by your responses. I didnt know that this provider was using MSAzure.

also things have moved on a little. I had found this post


And tried using the quick and dirty method at the end. I then rain mailinanbox install but again it failed with the message
Failed to restart systemd-resolved.service: Unit systemd-resolved.service is masked.
I then unmasked the service and got the message
Removed /etc/systemd/system/systemd-resolved.service.
I then ran mail in a box install agian
The install then appeared to proceed much further giving the following messages
Installing nsd (DNS server)…
Generating DNSSEC signing keys…
Installing Postfix (SMTP server)…
Installing Dovecot (IMAP server)…
Creating new user database: /home/user-data/mail/users.sqlite
Installing OpenDKIM/OpenDMARC…
Installing SpamAssassin…
Removing apache…
Installing Nginx (web server)…
Installing Roundcube (webmail)…
Installing Nextcloud (contacts/calendar)…

Upgrading to Nextcloud version 17.0.2

Nextcloud is already latest version
Installing Z-Push (Exchange/ActiveSync server)…
Installing Mail-in-a-Box system management daemon…
Installing Munin (system monitoring)…
Waiting for the Mail-in-a-Box management daemon to start…
Waiting for the Mail-in-a-Box management daemon to start…
Waiting for the Mail-in-a-Box management daemon to start…
It has then stalled on this message and not proceeded.

Guys thanks for your help and interest so far. I have to stop for a couple of hours now to attend to other matters. I will check back later to see if you have further thoughts or explanations.

Thanks again.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.