System Status Check still lists deleted domain

I have archived a domain from my users and then deleted the domain directory from the server. When I visit the System Status Check page it still lists this domain. Of course it shows many errors for it.

How do I get this removed from the Status Check?

Any slight possibility that you missed a Custom DNS record when deleting the domain?

I have seen that cause this before.

Yes, this was likely the problem. I have learned that you need to delete Custom DNS records first and then remove the domain.

Thanks for the reply.

The deleted domain is still listed there. Is there a way to remove it? I tried adding the domain back to the server, remove all Custom DNS, and then deleting the domain. No change so far and it doesn’t give any errors.

@drdandc Did you ever figure this out?

Hopefully this helps someone else; I ran into the same problem. Check the Aliases page and see if you have any aliases for that domain. If you do, delete all the aliases for the domain as well. That fixed it for me on Ubuntu 22.04 LTS with MiaB v65.