Stuck on DNS MX settings


#1

Greetings!

I red a bunch of topics on this forum, but I still have an issue that perhaps someone can help me resolving.

I have a web server hosting a bunch of websites and a MiaB server taking care of emails (so two separate servers on the same public IP).

The DNS settings (GoDaddy) are set where the A record points to my public IP and the MX record points to my mail MiaB domain: mail(dot)example(dot)com

Now, in my GoDaddy DNS I have entered the same exact MX record (my MiaB domain) for all my domains [mail(dot)example(dot)com]

Well, so far all goes well, every domain can send and receive email, however, with exception for my MiaB domain [mail(dot)example(dot)com] when testing DNS settings i have one error popping up:

“MX name validity”
The MX records that do not seem valid hostname:
mail.example.com
This can cause problems

it is because all of my domains point the MX record to my MiaB domain name [mail(dot).example(dot)com]

If I change the MX records for each domain to point to their own mail subdomain [mail(dot)domain1(dot)com] etc, rather than to my MiaB domain than the error is gone but the mail does not get delivered (I can still send emails thou).

So, I’m thinking, I need to make some adjustments in MiaB DNS for each domain right?
My question is - HOW, since I still want my email addresses to be me@domain1(dot)com me@domain2(dot)com etc…

Any ideas, please?

Thanks in advance!!


#2

Please share with me your hostname of your MiaB install in PM. And also please clarify the following statement:

How are two separate servers running on the same IP address? What is your definition of ‘server’?


#3

That’s perfectly simple. Port forwarding does the trick. :wink:

My web server runs of ports 80 and 443 while mail server runs on bunch of ports needed for mail server to operate properly.
Please note, I do not host my webpages on MiaB. I access my MiaB web interface through port 4400 [ mail(dot)domain(dot)com:4400/mail ]


#4

I kind of figured as much, though honestly, I am not much of a fan … that is just me though. That said … which web server are you using? I hope that you realize that this is not sustainable as MiaB will overwrite everything when it upgrades. It is for this reason that MiaB is required to be hosted on a VPS dedicated to MiaB.


#5

Where are you seeing the error message that you initially reported @alldigitalmagic?

Perhaps not the fix you’d prefer but the path of least resistance may be to use another domain to act as the domain for your MX if that is an option. I for one am out of suggestions at this point until I know more about where the error is presenting itself.


#6

I greatly appreciate your comments, thanks!
For starters, I use Ubuntu 16.04 for my web server with LAMP. I’m considering moving my MiaB to another static external IP next week to resolve the port forwarding mess.
Another thing worth pointing out is the fact that i that my network is controlled by Untangle Firewall, where all the port forwarding takes place.
Nonetheless, the problem I’m having thou, is that all other domains I host on my MiaB (for email purpose only) report the MX error when MX record is set (at GoDaddy) to my MiaB domain.
Once I change the MX record to mail(dot)domain1(dot)com, instead of my MiaB domain the error does not popup, but the mail does not get delivered. So, back to square one: How do I set the MX record on MiaB for each domain I host on MiaB?
I hope this makes sense.
Also, please keep in mind, my emails are delivered at the current settings, however, with that MX record error I’m afraid that some mailboxes will reject my emails, thus this whole topic.


#7

Are you on a residential isp?

I use Untangle here at home. It is great. Seems to be effective at blocking the sites pushing malware at my wife.

Dennis


#8

I use Untangle at the local school. Great product, extremely flexible offering lots of customizations.


#9

to check my dns record I use intends.com.
when I punch in a domain I host on MiaB (for email purpose only) I see the error (see attached picture).

.

Mind you, the domain shown on the attached picture is my MiaB default domain, not the domain I run the DNS check for.


#10

Typo perhaps? That link returns a domain for sale.


#11

ahhh,

intonds.com

sorry about that.


#12

Clarification please …
ALL domains can send and receive email
or
ALL domains can send and receive email except for the mail.example.com domain

In other words, does the error message that you are seeing not seem to be effecting email delivery?

I am reading it that you cannot send and receive email on that domain - have I misread?


#13

All domains can send and receive mail for as long as the MX record for each domain is set to mail.adm.media (including adm.media)
Once the MX record for any domain is set to “mail.example.com” the mail does not get delivered and the MX error in “intodns.com” does not popup.

One other thing. I changed the MX record of one of my domains “equicafe.com” from mail.adm.media to mail.equicafe.com. I tried to send an email to this domain from my google account. Here is the error I received:

DNS Error: 3428156 DNS type ‘mx’ lookup of equicafe.com responded with code NOERROR 3428156 DNS type ‘aaaa’ lookup of mail.equicafe.com. responded with code NXDOMAIN 3428156 DNS type ‘a’ lookup of mail.equicafe.com. responded with code NXDOMAIN

So, the bottom line is If I want to avoid the MX error which may cause some of the mail servers to reject my emails, I would have to set the MX record of each domain to mail(dot)example(dot).com. However, I have no idea of how to make my MiaB receive the mail with such MX record.


#14

Ok, I misread/misunderstood the original post. :frowning:

The MX record for EVERY domain must be mail.adm.media. You have discovered this already. You would not set the MX record to mail.example.com because there is no mail server installed on that hostname. This is perfectly normal. The MX records main job is to tell the internet where to deliver email for a specific domain.

This is not what is causing receiving email servers to reject your mails. The test that you ran returned an error most likely because your rDNS (PTR record) is not set to mail.adm.media.

Your emails are being rejected because many receiving mail servers are configured to block email when the rDNS does not match the hostname that the mail is being sent from. Which in your self-hosted scenario is almost guaranteed to not happen. You need to contact your ISP and request that the PTR be changed to mail.adm.media. Almost all ISP’s will NOT do this by policy. Some will if you have a business class account.

So, the bottom line is that this is a perfect example why it is so highly frowned upon to self-host at home. You need to get the PTR record changed, or change your hosting arrangement for MiaB.

I am sorry it took so long to get to this conclusion. I was under the incorrect impression that mail for adm.media was not being delivered when the MX record was properly set. While in fact, your OP simply stated that you saw this seemingly related error.


#15

I much appreciate your replies. I now have a clear picture of the problem and what causes it. Thank You!
Just to clarify, I do have a business class account with my ISP so I will get on their case tomorrow to do the necessary changes.

I truly appreciate your time and help!
Thank You!


#16

Excellent! I am glad that this is the case. I am always happy to help - I’m just sorry that it took me so long to read and reread the OP and look at things with a different perspective. The tip to me that I was looking at the wrong thing was when I checked intodns.com and saw their fine print concerning the results that they were returning. Then everything clicked!


closed #17

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.