Ssh broken pipe

Hello, everyone and Happy new year.
I don’t know what happens, but all of the sudden my network is going wild. I am not doing anything, and I get the message:
"client_loop: send disconnect: Broken pipe
" and no more server, no more ssh. I try to reconnect, and nothing. If I do hard reset (holding the button until it drops dead, and then pushing it again and restarting the computer it works a while, untill it comes back to the same result - beeing connected over ssh).
Plus I had no acces to the server, so I ran sudo mailinabox. after a while I could access it by https://public.ip/amin and showed me some errors:
the rDNS (which I still cannot resolve it with my ISP) and MST (os MTS policy… none). If I run nslookup I get SERVFAIL (I understand that it is unreacheable, wright?? - forgive my lack of solid knowledge, please.).
So is it necessary a new install or I can get it to work somehow? If so, how exactly? Thanks in advance… (

This sounds like a problem outside of anything to do with MiaB. Likely either a hardware problem or severe misconfiguration.

If possible, connect a monitor and keyboard to log and troubleshoot. Hard resets can create other problems.

I understand. Funny thing though, trying to access my from the mobile it worked without any problem.
ANd I still cannot provide the TLS certificaste, no matter how many times I press the button Provision. Should I wait untill they expire? Weren’t they supposed to renew automaticaly (or did I understand wrong?). Any suggestions???
As about the disconnection maybe the problem relies in my mac (that’s where I ususally connect over ssh to my miab server or my raspberrypi - which also suffers from disconnections constantly…).
Thanks for the answer, by the way.

Edit: this morning, after rebooting the system I still have this error message:
MTA-STS policy is missing: STSFetchResult.NONE
The TLS (SSL) certificate has a problem: The certificate is expiring soon: The certificate expires in 6 days on 2022-01-16.

client_loop: send disconnect: Broken pipe could be anything from the SSH session timing out due to excessive traffic to something far more serious with the server itself.

If a hard reset of the server fixes it, you need to look at your server and figure out what is causing it to lock up.

If I remember correctly, you’re running MIAB on your LAN on a Raspberry Pi, right? If that’s the case, you should seriously consider moving to the documented configuration, at least until you can get some understanding about how MIAB works and what it does. As it stands, it seems like you’re trying to give yourself a crash course in mail server administration, general linux administration, and networking at the same time. While this can certainly be done, at some point (if it hasn’t happened already :slight_smile: ) it’s going to get exceptionally frustrating.

If you want to continue down the current path, you might want to start by providing a network diagram of some sort, and consider not obfuscating your domain in your request for help.

TOtally right you are - frustrating it is…
But no, my miab instance is running on an old Toshiba laptop (I am not that able to make miab run on a raspberry pi -jejeje).
I’m still trying to figure out how to solve the tls problem - in the meanwhile I’am having a fight with the raspberry - it seems that today nothing works - and this time I really didn’t do anything…
Well - the beauty of informatics as they say here… jeejeje
Thanks for the help. I will keep you all informed.

Well, I have bad news for me, hahah. THe old Toshiba laptop just got himself into troubles which I cannot explain (the network adapter started to randomly reset itself, and leaving me without connectivity). So I replace it with an Acer, 2/3 years “younger”. ALso I started with a brand new installation of ubuntu and MIAB (version 0.55).
And the problems begun:
I get the “Public DNS (nsd4) is not running (port 53)”. The systemctl status is (sudo systemctl status nsd.service ● nsd.service - Name Server Daemon Loade -
And the TLS (formerly known as SSL) certficates: only one of them and with warning (the rest of them are “absent” - and honestly I don’t know how to solve or install). Also I noticed that in this version there is no Provision button for the certificates.
FUnny thing: I can access it by https://publicip/admin but not by (I imagine it’s because of the certificates problems?).
I tried to stop bind9 but got more errors, so I turned it on again.
I am at the point of not knowing what to do, or if I did something wrong, what, or how to make my maib work again as smooth as it did until the 2nd or 3rd of january - when everything started to just go wrong. (without me doing anything, hahaha).

Edit: I changed the DNSSEC record and the Provision buttona appeared. But still cannot provide the certificates: I get error of “Waiting for verification… Cleaning up challenges Failed authorization procedure” and “DNS problem: query timed out looking up A for mta-sts.” (that means what? because of the nsd4 service I get these errors?).

Late edit: here - Saving debug log to /var/log/letsencrypt/letsencrypt.log Plugins selected: Authe - - the log of the error of the certificates provision. Please, anyone could help me out - at least to understand the error? and maybe solve it?
Do please forgive my lack of solid knowledge - I am just an amateur self-taught…

Good evening. Recent descovery: just mapped in the router the port 80 (I hadn’t mapped it before). Almost all certificate were provided. THe only one still unistalled is the mta-sts and also the is like this: “Self-signed. Get a signed certificate to stop warnings.”
How could I resolve these last two ones?
Thanks in advance for the help.
Edit - all certificates are installed. Refreshed the page and they look allright. I’m gonna try and access the page usint the domain (hopefully it’ll work - it does).
So the thread can be closed. THanks all for the help.