Sqlite database lock

I tried to import my gmail contacts into owncloud but the connection timed out. Now I am getting a

general error 5: database locked

when I try to re-import contacts. Any solution to this?

It’s probably still churning on the first import.

Easiest way to force it to stop would be to reboot the machine. Or on the machine:

sudo service php5-fpm restart

Tried rebooting and the above command still get

An exception occurred while executing 'INSERT INTO "oc_filecache" ("mimepart","mimetype","mtime","size","etag","storage_mtime","permissions","parent","path_hash","path","name","storage") SELECT ?,?,?,?,?,?,?,?,?,?,?,? WHERE NOT EXISTS (SELECT 1 FROM "oc_filecache" WHERE "storage" = ? AND "path_hash" = ?)' with params ["3", "10", 1441025149, 1, "280e6b4a9bc12d221823e0362798b06e", 1441025149, 27, "11", "fe7d316543a8085a49b4c0e77e631908", "cache\/contacts-import-1868126474", "contacts-import-1868126474", "3", "3", "fe7d316543a8085a49b4c0e77e631908"]: SQLSTATE[HY000]: General error: 5 database is locked

Then the import stops.

I don’t know what to tell you, unfortunately. It seems like it just can’t handle a large import.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.