[Solved] Unable to resolve host during setup

MIAB installation behind a firewall:

during setup process it states:

Installing Nginx (web server)…
Installing Roundcube (webmail)…
sudo: unable to resolve host box.xy.com


box.xy.com DNS isn`t configured properly for this domain: DNS resolvers failed to answer the query box.xy.com. IN A: Server DNS operation timed out (…)

dig “box.xy.com” (entered during setup of MIAB) shows:

box.xy.com. xxx IN A 99.999.99.999

xy.com. xxx IN NS ns1.box.xy.com
xy.com. xxx IN NS ns1.box.xy.com

ns1.box.xy.com xxx IN A 99.999.99.999
ns1.box.xy.com xxx IN A 99.999.99.999

(looks good)

/etc/hosts entry on MIAB: localhost mailinabox

Information during setup:
Primary Hostname: box.xy.com
Public IP Address: 99.999.99.999
Private IP: 192.168.x.xx
Private IVP6 Address: (…)
MIAB Version: v0.22

Any help in regards to the “unable to resolve host” problem during setup?

This issue was due to a firewall problem: Port 53 (both: TCP and UDP) was set properly in a port group rule, but for some reasons, UDP did not worked until one puts port 53 in a separate (stand-alone) rule. [Solved]