"SOLVED...sort of" Glue Records status check error after clean install

Hey everyone, I seem to be having a similar problem as a few other posts yet the solutions they found do not seem to be working for me. The specific errors I am getting after setup are:

		Nameserver glue records are incorrect. The ns1.box.MYDOMAIN.com
		and ns2.box.MYDOMAIN.com nameservers must be configured at your
		domain name registrar as having the IP address
		They currently report addresses of [Not Set]/[Not Set]. It may
		take several hours for public DNS to update after a change.
		This domain must resolve to your box's IP address
		( in public DNS but it currently resolves to [Not
		Set]. It may take several hours for public DNS to update after a
		change. This problem may result from other issues listed above.

The glue records, named correctly, have been set through namecheap which I validated through mxtoolbox, pingability, and nslookup that they are working correctly. I am running the server behind pfSense with all ports forwarded (TCP&UDP) correctly. The interesting thing is that DNS IS working…when I browse to https://box.mydomain.com/admin from several systems, everything works. I am not sure if I should try to bypass the status checks to get SSL established correctly (currently using self signed) or if there is something I am missing on this. I checked with a friend’s server who uses mailinabox and has no errors. The only difference I can find between us is pfSense since we both did clean installs.

Other things I have tried without success:
-set up NAT translation in pfSense to assist internal checks. This solved errors with system status checks for IMAP/SMTP. I believe this means the NAT hairpin is working correctly.
-clean install
-checked DNSSEC was turned off at namecheap
-added mydomain.com box.mydomain.com www.mydomain.com to /etc/hosts file (no result, then removed)
-tried vfw -disable (no result, turned back on)
-service nsd restart (also included bind9 after, no result)

Other notes:
-ownCloud works
-email works
-i set up SSH to allow root login, it works

If anyone has any recommendations of what else I can try, please let me know. I am out of ideas…

So i just checked today and the system checks worked perfect. I waited the appropriate 48 hours recommended but apparently it can take as long as 5 days for it to propagate? I’m still not sure why the tools like mxtoolbox found the glue records while the system check didn’t but since it is working i am going to stop exerting mental energy on it.